aboutsummaryrefslogtreecommitdiffstats
path: root/embed/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@gnome.org>2007-07-28 04:27:56 +0800
committerXan Lopez <xan@src.gnome.org>2007-07-28 04:27:56 +0800
commitc75bf8633191306efc4120fd589d0c375f286e71 (patch)
treee573b99549ca95c38ef67c9dd5d53829cb545a30 /embed/Makefile.am
parentec7067fd30fe1bd5d0b69a648359d8085328f398 (diff)
downloadgsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.gz
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.bz2
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.lz
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.xz
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.zst
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.zip
Add support for the WebKit engine, compile with --with-engine=webkit to
2007-07-27 Xan Lopez <xan@gnome.org> * Makefile.am: * configure.ac: * doc/reference/Makefile.am: * embed/Makefile.am: * embed/ephy-embed-factory.c: (ephy_embed_factory_new_object): * embed/ephy-embed-persist.c: * embed/ephy-embed-shell.c: * embed/ephy-embed.c: * embed/webkit/Makefile.am: * embed/webkit/webkit-embed-find.cpp: * embed/webkit/webkit-embed-find.h: * embed/webkit/webkit-embed-persist.cpp: * embed/webkit/webkit-embed-persist.h: * embed/webkit/webkit-embed-single.cpp: * embed/webkit/webkit-embed-single.h: * embed/webkit/webkit-embed.cpp: * embed/webkit/webkit-embed.h: * src/Makefile.am: Add support for the WebKit engine, compile with --with-engine=webkit to activate. * embed/mozilla/mozilla-embed-single.cpp: Move to the G_DEFINE_TYPE_WITH_CODE macro. svn path=/trunk/; revision=7208
Diffstat (limited to 'embed/Makefile.am')
-rw-r--r--embed/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/embed/Makefile.am b/embed/Makefile.am
index 68859851f..e073b5d57 100644
--- a/embed/Makefile.am
+++ b/embed/Makefile.am
@@ -1,4 +1,5 @@
-SUBDIRS = mozilla
+SUBDIRS = $(with_engine)
+DIST_SUBDIRS = mozilla webkit
noinst_LTLIBRARIES = libephyembed.la libephyembedfactory.la
@@ -72,14 +73,12 @@ nodist_libephyembed_la_SOURCES = \
libephyembed_la_CPPFLAGS = \
-I$(top_builddir)/lib \
- -I$(top_srcdir)/embed/mozilla \
-I$(top_srcdir)/lib \
-I$(top_srcdir)/lib/egg \
-I$(top_srcdir)/lib/widgets \
$(AM_CPPFLAGS)
libephyembed_la_CFLAGS = \
- -I$(GECKO_INCLUDE_ROOT)/gtkembedmoz \
-DSHARE_DIR=\"$(pkgdatadir)\" \
$(DEPENDENCIES_CFLAGS) \
$(AM_CFLAGS)
@@ -89,10 +88,13 @@ libephyembedfactory_la_SOURCES = \
ephy-embed-factory.h
libephyembedfactory_la_CPPFLAGS = \
- -I$(top_srcdir)/embed/mozilla \
- -I$(GECKO_INCLUDE_ROOT)/gtkembedmoz \
+ -I$(top_srcdir)/embed/$(with_engine) \
$(AM_CPPFLAGS)
+if WITH_GECKO_ENGINE
+libephyembedfactory_la_CPPFLAGS += -I$(GECKO_INCLUDE_ROOT)/gtkembedmoz
+endif
+
libephyembedfactory_la_CFLAGS = \
$(DEPENDENCIES_CFLAGS) \
$(AM_CFLAGS)