aboutsummaryrefslogtreecommitdiffstats
path: root/doc/reference/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@gnome.org>2003-11-19 01:25:26 +0800
committerMarco Pesenti Gritti <marco@src.gnome.org>2003-11-19 01:25:26 +0800
commita8e72a5659769e3f1295d6d35092e8be579db7bb (patch)
treecfefdf912e17a1de56ba7a14caef2ff191b679de /doc/reference/Makefile.am
parent0ecd2e8f08325aea9fbe1f3869ae76d460d4c5b8 (diff)
downloadgsoc2013-epiphany-a8e72a5659769e3f1295d6d35092e8be579db7bb.tar
gsoc2013-epiphany-a8e72a5659769e3f1295d6d35092e8be579db7bb.tar.gz
gsoc2013-epiphany-a8e72a5659769e3f1295d6d35092e8be579db7bb.tar.bz2
gsoc2013-epiphany-a8e72a5659769e3f1295d6d35092e8be579db7bb.tar.lz
gsoc2013-epiphany-a8e72a5659769e3f1295d6d35092e8be579db7bb.tar.xz
gsoc2013-epiphany-a8e72a5659769e3f1295d6d35092e8be579db7bb.tar.zst
gsoc2013-epiphany-a8e72a5659769e3f1295d6d35092e8be579db7bb.zip
Begin of gtk-doc support
2003-11-18 Marco Pesenti Gritti <marco@gnome.org> * Makefile.am: * configure.in: * doc/Makefile.am: * doc/reference/Makefile.am: * doc/reference/epiphany-docs.sgml: * doc/reference/epiphany.types: Begin of gtk-doc support
Diffstat (limited to 'doc/reference/Makefile.am')
-rw-r--r--doc/reference/Makefile.am63
1 files changed, 63 insertions, 0 deletions
diff --git a/doc/reference/Makefile.am b/doc/reference/Makefile.am
new file mode 100644
index 000000000..f0810ec55
--- /dev/null
+++ b/doc/reference/Makefile.am
@@ -0,0 +1,63 @@
+## Process this file with automake to produce Makefile.in
+AUTOMAKE_OPTIONS = 1.6
+
+# The name of the module
+DOC_MODULE=epiphany
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
+
+# The directory containing the source code. Relative to $(srcdir).
+# gtk-doc will search all .c & .h files beneath here for inline comments
+# documenting functions and macros.
+DOC_SOURCE_DIR=../../lib
+
+# Extra options to supply to gtkdoc-scan.
+SCAN_OPTIONS=
+
+# Extra options to supply to gtkdoc-mkdb.
+MKDB_OPTIONS=--sgml-mode --output-format=xml
+
+# Extra options to supply to gtkdoc-fixref.
+FIXXREF_OPTIONS=
+
+# Used for dependencies.
+HFILE_GLOB=
+CFILE_GLOB=
+
+# Header files to ignore when scanning.
+IGNORE_HFILES=
+
+# Images to copy into HTML directory.
+HTML_IMAGES =
+
+# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
+content_files =
+
+# Other files to distribute.
+extra_files =
+
+# CFLAGS and LDFLAGS for compiling scan program. Only needed
+# if $(DOC_MODULE).types is non-empty.
+GTKDOC_CFLAGS = -I$(top_srcdir)/src \
+ -I$(top_srcdir)/lib \
+ -I$(top_srcdir)/lib/widgets \
+ -I$(top_srcdir)/embed \
+ -I$(top_srcdir)/embed/mozilla \
+ -I$(top_srcdir)/src/bookmarks \
+ $(EPIPHANY_DEPENDENCY_CFLAGS)
+
+GTKDOC_LIBS = \
+ $(top_builddir)/embed/libephyembed.la \
+ $(top_builddir)/lib/libephy.la \
+ $(top_builddir)/src/bookmarks/libephybookmarks.la \
+ $(top_builddir)/src/libephymain.la \
+ $(EPIPHANY_DEPENDENCY_LIBS)
+
+# If you need to override some of the declarations, place them in the
+# $(DOC_MODULE)-overrides.txt file and uncomment the second line here.
+DOC_OVERRIDES =
+
+# include common portion ...
+include $(top_srcdir)/gtk-doc.make
+