aboutsummaryrefslogtreecommitdiffstats
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <jmccann@redhat.com>2011-03-25 02:43:53 +0800
committerWilliam Jon McCann <jmccann@redhat.com>2011-03-25 02:45:56 +0800
commita257415a802566f27ac7e6bc9a34e6c9d4132bb3 (patch)
treee053eafd45311e783d27232bc12befe5a837f16b /data/icons/Makefile.am
parenta4b7844bb6ad0c25477f0bd8918a3edc33198f3e (diff)
downloadgsoc2013-epiphany-a257415a802566f27ac7e6bc9a34e6c9d4132bb3.tar
gsoc2013-epiphany-a257415a802566f27ac7e6bc9a34e6c9d4132bb3.tar.gz
gsoc2013-epiphany-a257415a802566f27ac7e6bc9a34e6c9d4132bb3.tar.bz2
gsoc2013-epiphany-a257415a802566f27ac7e6bc9a34e6c9d4132bb3.tar.lz
gsoc2013-epiphany-a257415a802566f27ac7e6bc9a34e6c9d4132bb3.tar.xz
gsoc2013-epiphany-a257415a802566f27ac7e6bc9a34e6c9d4132bb3.tar.zst
gsoc2013-epiphany-a257415a802566f27ac7e6bc9a34e6c9d4132bb3.zip
Use the web-browser icon from the GNOME icon theme
Instead of the low res version shipped internally. https://bugzilla.gnome.org/show_bug.cgi?id=645713
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am56
1 files changed, 2 insertions, 54 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
index b5bde31e2..08f65c63b 100644
--- a/data/icons/Makefile.am
+++ b/data/icons/Makefile.am
@@ -1,23 +1,5 @@
NULL =
-public_icons_themes = \
- hicolor \
- HighContrastLargePrint \
- HighContrastLargePrintInverse \
- LowContrastLargePrint \
- $(NULL)
-
-public_icons = \
- hicolor_apps_16x16_gnome-web-browser.png \
- hicolor_apps_22x22_gnome-web-browser.png \
- hicolor_apps_24x24_gnome-web-browser.png \
- hicolor_apps_32x32_gnome-web-browser.png \
- hicolor_apps_scalable_gnome-web-browser.svg \
- HighContrastLargePrint_apps_48x48_gnome-web-browser.png \
- HighContrastLargePrintInverse_apps_48x48_gnome-web-browser.png \
- LowContrastLargePrint_apps_48x48_gnome-web-browser.png \
- $(NULL)
-
private_icons = \
hicolor_actions_16x16_bookmark-view.png \
hicolor_actions_16x16_history-view.png \
@@ -64,9 +46,6 @@ noinst_DATA = \
hicolor_actions_32x32_history-view.svg \
hicolor_actions_16x16_bookmark-view.xcf \
hicolor_actions_22x22_bookmark-view.xcf \
- hicolor_apps_16x16_gnome-web-browser.svg \
- hicolor_apps_22x22_gnome-web-browser.svg \
- hicolor_apps_32x32_gnome-web-browser.svg \
hicolor_places_16x16_bookmark-web.svg \
hicolor_places_22x22_bookmark-web.svg \
hicolor_status_16x16_popup-hidden.xcf \
@@ -75,37 +54,13 @@ noinst_DATA = \
$(NULL)
EXTRA_DIST = \
- $(public_icons) \
$(private_icons) \
$(noinst_DATA) \
$(NULL)
###############################################################################
-gtk_update_icon_cache = gtk-update-icon-cache -f -t
-
-update-icon-cache:
- @-if test -z "$(DESTDIR)"; then \
- echo "Updating Gtk icon cache."; \
- for theme in $(public_icons_themes); do \
- $(gtk_update_icon_cache) $(datadir)/icons/$$theme; \
- done; \
- else \
- echo "*** Icon cache not updated. After (un)install, run this:"; \
- for theme in $(public_icons_themes); do \
- echo "*** $(gtk_update_icon_cache) $(datadir)/icons/$$theme"; \
- done; \
- fi
-
install-icons:
- for icon in $(public_icons); do \
- THEME=`echo $$icon | cut -d_ -f1`; \
- CONTEXT=`echo $$icon | cut -d_ -f2`; \
- SIZE=`echo $$icon | cut -d_ -f3`; \
- ICONFILE=`echo $$icon | cut -d_ -f4`; \
- mkdir -p $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT; \
- $(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
- done; \
for icon in $(private_icons); do \
THEME=`echo $$icon | cut -d_ -f1`; \
CONTEXT=`echo $$icon | cut -d_ -f2`; \
@@ -116,13 +71,6 @@ install-icons:
done
uninstall-icons:
- -for icon in $(public_icons); do \
- THEME=`echo $$icon | cut -d_ -f1`; \
- CONTEXT=`echo $$icon | cut -d_ -f2`; \
- SIZE=`echo $$icon | cut -d_ -f3`; \
- ICONFILE=`echo $$icon | cut -d_ -f4`; \
- rm -f $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
- done; \
for icon in $(private_icons); do \
THEME=`echo $$icon | cut -d_ -f1`; \
CONTEXT=`echo $$icon | cut -d_ -f2`; \
@@ -131,6 +79,6 @@ uninstall-icons:
rm -f $(DESTDIR)$(pkgdatadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
done
-install-data-local: install-icons update-icon-cache
+install-data-local: install-icons
-uninstall-local: uninstall-icons update-icon-cache
+uninstall-local: uninstall-icons