aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-11-13 00:48:50 +0800
committerChristian Persch <chpe@src.gnome.org>2005-11-13 00:48:50 +0800
commitd211a9678ff2a47bfcf6ce2ede0979f01f536fe9 (patch)
tree9922a9b38b4177e66d2d9b134f777bff2a500814 /data/Makefile.am
parentd0b96ec1c87ce1d5971a4cea9073c68843214a71 (diff)
downloadgsoc2013-epiphany-d211a9678ff2a47bfcf6ce2ede0979f01f536fe9.tar
gsoc2013-epiphany-d211a9678ff2a47bfcf6ce2ede0979f01f536fe9.tar.gz
gsoc2013-epiphany-d211a9678ff2a47bfcf6ce2ede0979f01f536fe9.tar.bz2
gsoc2013-epiphany-d211a9678ff2a47bfcf6ce2ede0979f01f536fe9.tar.lz
gsoc2013-epiphany-d211a9678ff2a47bfcf6ce2ede0979f01f536fe9.tar.xz
gsoc2013-epiphany-d211a9678ff2a47bfcf6ce2ede0979f01f536fe9.tar.zst
gsoc2013-epiphany-d211a9678ff2a47bfcf6ce2ede0979f01f536fe9.zip
Fix schemas install and add generate-font-schemas.py to EXTRA_DIST.
2005-11-12 Christian Persch <chpe@cvs.gnome.org> * data/Makefile.am: Fix schemas install and add generate-font-schemas.py to EXTRA_DIST.
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index e0e798c1a..79703f376 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -39,8 +39,9 @@ applicationsdir = $(datadir)/application-registry
applications_DATA = epiphany.applications
schemadir = $(GCONF_SCHEMA_FILE_DIR)
+font_schema_files = epiphany-fonts.schemas
schema_in_files = epiphany.schemas.in epiphany-lockdown.schemas.in
-schema_DATA = epiphany.schemas epiphany-lockdown.schemas
+schema_DATA = $(schema_in_files:.schemas.in=.schemas)
aboutdir = $(pkgdatadir)
about_DATA = epiphany.xhtml
@@ -59,18 +60,19 @@ xsl_DATA = \
epiphany-bookmarks-html.xsl \
ephy-xml2ini.xsl
-install-data-local:
+install-data-local: $(schema_DATA) $(font_schema_files)
if GCONF_SCHEMAS_INSTALL
if test -z "$(DESTDIR)" ; then \
- for p in $(schema_DATA) ; do \
- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(top_builddir)/data/$$p >&1 > /dev/null; \
+ for p in $^ ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p >&1 > /dev/null; \
done \
- fi
+ fi
endif
EXTRA_DIST = \
$(server_in_files) \
$(schema_in_files) \
+ $(font_schema_files) \
$(DESKTOP_IN_FILES) \
$(about_DATA) \
$(applications_DATA) \
@@ -79,7 +81,8 @@ EXTRA_DIST = \
$(default_prefs_in_FILES) \
$(xsl_DATA) \
$(m4data_DATA) \
- check-mime.py
+ check-mime.py \
+ generate-font-schemas.py
DISTCLEANFILES = \
$(server_DATA) \