aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-02-07 03:10:25 +0800
committerChristian Persch <chpe@src.gnome.org>2004-02-07 03:10:25 +0800
commitc6262af5f8d012b671ef3107577b765b1e9ff8a1 (patch)
tree7c16739efa77d429e27551e4f01b5f75da62386e /data/Makefile.am
parent3bdea3fdb3ddefb1cefe06aa21e37d5493312289 (diff)
downloadgsoc2013-epiphany-c6262af5f8d012b671ef3107577b765b1e9ff8a1.tar
gsoc2013-epiphany-c6262af5f8d012b671ef3107577b765b1e9ff8a1.tar.gz
gsoc2013-epiphany-c6262af5f8d012b671ef3107577b765b1e9ff8a1.tar.bz2
gsoc2013-epiphany-c6262af5f8d012b671ef3107577b765b1e9ff8a1.tar.lz
gsoc2013-epiphany-c6262af5f8d012b671ef3107577b765b1e9ff8a1.tar.xz
gsoc2013-epiphany-c6262af5f8d012b671ef3107577b765b1e9ff8a1.tar.zst
gsoc2013-epiphany-c6262af5f8d012b671ef3107577b765b1e9ff8a1.zip
Honour the --with-gconf-schema-file-dir and --disable-schemas-install
2004-02-06 Christian Persch <chpe@cvs.gnome.org> * data/Makefile.am: Honour the --with-gconf-schema-file-dir and --disable-schemas-install configure options. Patch by Julio M. Merino Vidal, fixes bug #133533.
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 999810340..699ebd698 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -27,7 +27,7 @@ desktop_DATA = $(DESKTOP_FILES)
applicationsdir = $(datadir)/application-registry
applications_DATA = epiphany.applications
-schemadir = $(sysconfdir)/gconf/schemas
+schemadir = $(GCONF_SCHEMA_FILE_DIR)
schema_in_files = epiphany.schemas.in epiphany-lockdown.schemas.in
schema_DATA = epiphany.schemas epiphany-lockdown.schemas
@@ -41,11 +41,13 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = epiphany-1.0.pc
install-data-local:
+if GCONF_SCHEMAS_INSTALL
if test -z "$(DESTDIR)" ; then \
for p in $(schema_DATA) ; do \
GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(top_builddir)/data/$$p; \
done \
fi
+endif
EXTRA_DIST = $(NAUTILUS_VIEW_SERVER) \
$(server_in_files) \