aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@it.gnome.org>2002-12-31 22:39:34 +0800
committerMarco Pesenti Gritti <mpeseng@src.gnome.org>2002-12-31 22:39:34 +0800
commit90870f6628f09e7e46693c95c9237b602960f1ab (patch)
tree8c20c2af38faaa27cde6c1892181003b3576a09b /data/Makefile.am
parent48f720de8614cb0463d5d1738a2e936337b58e46 (diff)
downloadgsoc2013-epiphany-90870f6628f09e7e46693c95c9237b602960f1ab.tar
gsoc2013-epiphany-90870f6628f09e7e46693c95c9237b602960f1ab.tar.gz
gsoc2013-epiphany-90870f6628f09e7e46693c95c9237b602960f1ab.tar.bz2
gsoc2013-epiphany-90870f6628f09e7e46693c95c9237b602960f1ab.tar.lz
gsoc2013-epiphany-90870f6628f09e7e46693c95c9237b602960f1ab.tar.xz
gsoc2013-epiphany-90870f6628f09e7e46693c95c9237b602960f1ab.tar.zst
gsoc2013-epiphany-90870f6628f09e7e46693c95c9237b602960f1ab.zip
Build .in data files from the makefile, not from configure.in. Add a
2002-12-31 Marco Pesenti Gritti <marco@it.gnome.org> * configure.in: * data/.cvsignore: * data/Makefile.am: Build .in data files from the makefile, not from configure.in. Add a desktop file. We badly need an icon ;)
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 60b11c546..e5d584df7 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -7,6 +7,12 @@ server_in_files = GNOME_Epiphany_Automation.server.in GNOME_Epiphany_NautilusVie
server_DATA = GNOME_Epiphany_Automation.server GNOME_Epiphany_NautilusView.server
serverdir = $(libdir)/bonobo/servers
+DESKTOP_IN_FILES=epiphany.desktop.in
+DESKTOP_FILES=$(DESKTOP_IN_FILES:.desktop.in=.desktop)
+
+Applicationsdir = $(datadir)/applications
+Applications_DATA = $(DESKTOP_FILES)
+
schemadir = $(sysconfdir)/gconf/schemas
schema_DATA = epiphany.schemas
@@ -22,8 +28,10 @@ install-data-local:
done \
fi
-CLEANFILES = GNOME_Epiphany_Automation.server
+CLEANFILES = $(server_DATA) $(Applications_DATA)
+
+EXTRA_DIST = $(server_in_files) \
+ $(schema_DATA) \
+ $(starthere_DATA) \
+ $(DESKTOP_IN_FILES)
-EXTRA_DIST = $(server_in_files) \
- $(schema_DATA) \
- $(starthere_DATA)