aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@it.gnome.org>2003-06-15 23:00:42 +0800
committerMarco Pesenti Gritti <mpeseng@src.gnome.org>2003-06-15 23:00:42 +0800
commitd9dbf128b234992f938c6800f31891800c68626c (patch)
tree1c4d71356cc6cc7c82498a031765277e9182bf72 /configure.in
parent3af933af0fb76029084541a4ecb0e85d9938e58e (diff)
downloadgsoc2013-epiphany-d9dbf128b234992f938c6800f31891800c68626c.tar
gsoc2013-epiphany-d9dbf128b234992f938c6800f31891800c68626c.tar.gz
gsoc2013-epiphany-d9dbf128b234992f938c6800f31891800c68626c.tar.bz2
gsoc2013-epiphany-d9dbf128b234992f938c6800f31891800c68626c.tar.lz
gsoc2013-epiphany-d9dbf128b234992f938c6800f31891800c68626c.tar.xz
gsoc2013-epiphany-d9dbf128b234992f938c6800f31891800c68626c.tar.zst
gsoc2013-epiphany-d9dbf128b234992f938c6800f31891800c68626c.zip
Use new INIT macros (from galeon).
2003-06-15 Marco Pesenti Gritti <marco@it.gnome.org> * configure.in: Use new INIT macros (from galeon). * embed/ephy-embed-event.c: (ephy_embed_event_get_coords): * embed/ephy-embed-event.h: * embed/mozilla/EventContext.cpp: * embed/mozilla/EventContext.h: * embed/mozilla/mozilla-embed.cpp: mozilla api changes (from galeon). Untested.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 13 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 2fcfd7037..282cce0e4 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,15 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(configure.in)
-AC_PREREQ(2.50)
+AC_INIT(epiphany, 0.7.1,
+ [http://bugzilla.gnome.org/enter_bug.cgi?product=epiphany])
+
+AM_CONFIG_HEADER(config.h)
+AC_CONFIG_SRCDIR(configure.in)
+
+AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
+
+dnl put the ACLOCAL flags in the Makefile
+ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
GCONF_REQUIRED=1.0.4
GDK_PIXBUF_REQUIRED=0.13.0
@@ -14,7 +22,7 @@ GTK_REQUIRED=1.2.9
LIBXML_REQUIRED=1.8.14
OAF_REQUIRED=0.6.5
ORBIT_REQUIRED=0.5.7
-MOZILLA_REQUIRED=1.1
+MOZILLA_REQUIRED=1.3
SCROLLKEEPER_REQUIRED=0.1.4
LIBBONOBOUI_REQUIRED=2.1.1
@@ -30,9 +38,6 @@ AC_SUBST(LIBBONOBOUI_REQUIRED)
AC_ENABLE_SHARED(yes)
AC_ENABLE_STATIC(no)
-AM_INIT_AUTOMAKE(epiphany, 0.7.0)
-AM_CONFIG_HEADER(config.h)
-
AM_PROG_LIBTOOL
AC_ISC_POSIX
@@ -45,8 +50,6 @@ AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
AC_SUBST(AM_CXXFLAGS)
-ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
-
GNOME_DEBUG_CHECK
GNOME_COMPILE_WARNINGS(error)
@@ -194,8 +197,8 @@ case "$MOZILLA_VERSION" in
1.4a) MOZILLA_SNAPSHOT=7 ;;
1.4b) MOZILLA_SNAPSHOT=7 ;;
1.4) MOZILLA_SNAPSHOT=8 ;;
- 1.5a) MOZILLA_SNAPSHOT=8 ;;
-trunk) MOZILLA_SNAPSHOT=8 ;;
+ 1.5a) MOZILLA_SNAPSHOT=9 ;;
+trunk) MOZILLA_SNAPSHOT=9 ;;
*) AC_ERROR([
*****************************************************************************
Epiphany can be built using Mozilla 1.3, 1.3.1, 1.4a, 1.4b, 1.4, 1.5a or