aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@it.gnome.org>2003-04-05 04:33:39 +0800
committerMarco Pesenti Gritti <mpeseng@src.gnome.org>2003-04-05 04:33:39 +0800
commitd95d1dfa398383b0b6446d63b96dc4e2e3a972ff (patch)
tree5aa0ef163db61100ee49a40b929f304909cc5539 /configure.in
parent47015d29a0d473474643f1cdffcec8e437c60b64 (diff)
downloadgsoc2013-epiphany-d95d1dfa398383b0b6446d63b96dc4e2e3a972ff.tar
gsoc2013-epiphany-d95d1dfa398383b0b6446d63b96dc4e2e3a972ff.tar.gz
gsoc2013-epiphany-d95d1dfa398383b0b6446d63b96dc4e2e3a972ff.tar.bz2
gsoc2013-epiphany-d95d1dfa398383b0b6446d63b96dc4e2e3a972ff.tar.lz
gsoc2013-epiphany-d95d1dfa398383b0b6446d63b96dc4e2e3a972ff.tar.xz
gsoc2013-epiphany-d95d1dfa398383b0b6446d63b96dc4e2e3a972ff.tar.zst
gsoc2013-epiphany-d95d1dfa398383b0b6446d63b96dc4e2e3a972ff.zip
Use mozilla-config.h instead of hacks.
2003-04-04 Marco Pesenti Gritti <marco@it.gnome.org> * configure.in: * embed/mozilla/Makefile.am: Use mozilla-config.h instead of hacks.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7e252255e..265ae5b48 100644
--- a/configure.in
+++ b/configure.in
@@ -142,6 +142,33 @@ fi
AM_GCONF_SOURCE_2
+dnl This is from Mozilla's configure.in. They set almost all the config stuff
+dnl they need in mozilla-config.h Except for this compiler flag, which can't
+dnl go in mozilla-config.h So we check the flag too and now we can include
+dnl mozilla-config.h without breaking galeon.
+dnl This is really gcc-only
+dnl Do this test using CXX only since some versions of gcc
+dnl 2.95-2.97 have a signed wchar_t in c++ only and some versions
+dnl only have short-wchar support for c++.
+AC_LANG_PUSH(C++)
+_SAVE_CXXFLAGS=$CXXFLAGS
+CXXFLAGS="$CXXFLAGS -fshort-wchar"
+
+AC_CACHE_CHECK(for compiler -fshort-wchar option,
+ ac_cv_have_usable_wchar_option,
+ [AC_TRY_RUN([#include <stddef.h>
+ int main () {
+ return (sizeof(wchar_t) != 2) ||
+ (wchar_t)-1 < (wchar_t) 0 ; } ],
+ ac_cv_have_usable_wchar_option="yes",
+ ac_cv_have_usable_wchar_option="no",
+ ac_cv_have_usable_wchar_option="maybe")])
+
+if test "$ac_cv_have_usable_wchar_option" != "yes"; then
+ CXXFLAGS=$_SAVE_CXXFLAGS
+fi
+AC_LANG_POP(C++)
+
dnl *******************************
dnl Internationalization
dnl *******************************