aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-01-02 04:55:00 +0800
committerChristian Persch <chpe@src.gnome.org>2005-01-02 04:55:00 +0800
commitcd2cd1d96b0d372fe53c27554e7808e34181f085 (patch)
tree27b583ffc4b9693a3da1b38752bf8c6975fc690f /configure.in
parentac3dc7dec3ab0e5edb609d4bf0f11fb77913b033 (diff)
downloadgsoc2013-epiphany-cd2cd1d96b0d372fe53c27554e7808e34181f085.tar
gsoc2013-epiphany-cd2cd1d96b0d372fe53c27554e7808e34181f085.tar.gz
gsoc2013-epiphany-cd2cd1d96b0d372fe53c27554e7808e34181f085.tar.bz2
gsoc2013-epiphany-cd2cd1d96b0d372fe53c27554e7808e34181f085.tar.lz
gsoc2013-epiphany-cd2cd1d96b0d372fe53c27554e7808e34181f085.tar.xz
gsoc2013-epiphany-cd2cd1d96b0d372fe53c27554e7808e34181f085.tar.zst
gsoc2013-epiphany-cd2cd1d96b0d372fe53c27554e7808e34181f085.zip
We don't need to implement nsIBrowserHistory.
2005-01-01 Christian Persch <chpe@cvs.gnome.org> * configure.in: * embed/mozilla/GlobalHistory.cpp: * embed/mozilla/GlobalHistory.h: We don't need to implement nsIBrowserHistory.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 1 insertions, 39 deletions
diff --git a/configure.in b/configure.in
index ac2deb92e..70ffbd127 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([GNOME Web browser], [1.4.7.90],
+AC_INIT([GNOME Web browser], [1.4.8],
[http://bugzilla.gnome.org/enter_bug.cgi?product=epiphany],[epiphany])
GNOME_COMMON_INIT
@@ -252,44 +252,6 @@ AC_DEFINE_UNQUOTED([MOZ_NSICONTENTPOLICY_VARIANT], [$variant], [Define the nsICo
AC_MSG_RESULT([variant $variant])
-dnl Changed from char* to nsIURI* in 1.7.4 on 1.7 branch,
-dnl in 1.8a3 on trunk and on aviary branch
-
-AC_MSG_CHECKING([whether nsIBrowserHistory methods expect nsIURI*])
-
-AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM(
- [[#include <nsIURI.h>
- #include <nsIGlobalHistory.h>
- #include <docshell/nsIGlobalHistory2.h>
- #include <history/nsIBrowserHistory.h>]],
- [[nsIBrowserHistory* p;
- nsIURI *arg1;
- p->RemovePage(arg1);]]
- )],
- [AC_DEFINE([MOZ_NSIGLOBALHISTORY_NSIURIP],[1],[Define if nsIBrowserHistory methods expect nsIURI*]) result=yes],
- [result=no])
-
-AC_MSG_RESULT([$result])
-
-dnl This is only present in new-toolkit apps
-
-AC_MSG_CHECKING([for nsIBrowserHistory::AddPageWithDetails])
-
-AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM(
- [[#include <nsIURI.h>
- #include <nsIGlobalHistory.h>
- #include <docshell/nsIGlobalHistory2.h>
- #include <history/nsIBrowserHistory.h>]],
- [[nsIBrowserHistory *p;
- p->AddPageWithDetails(nsnull,nsnull,0);]]
- )],
- [AC_DEFINE([MOZ_NSIBROWSERHISTORY_ADDPAGEWITHDETAILS],[1],[Define if nsIBrowserHistory::AddPageWithDetails exists]) result=yes],
- [result=no])
-
-AC_MSG_RESULT([$result])
-
dnl changed in 1.8a4
AC_MSG_CHECKING([for whether nsIGlobalHistory2::AddURI takes a referrer])