aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@it.gnome.org>2003-07-13 16:52:36 +0800
committerMarco Pesenti Gritti <mpeseng@src.gnome.org>2003-07-13 16:52:36 +0800
commit9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec (patch)
tree089536612813c5504f5fe5a35184e3ff23a8adcd /configure.in
parentf73556913d8a794f6c8ed17a7664d0a2f61635da (diff)
downloadgsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.tar
gsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.tar.gz
gsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.tar.bz2
gsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.tar.lz
gsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.tar.xz
gsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.tar.zst
gsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.zip
2003-07-13 Marco Pesenti Gritti <marco@it.gnome.org>
* Makefile.am: * configure.in: * embed/Makefile.am: * embed/ephy-embed-shell.c: (ephy_embed_shell_get_favicon_cache), (impl_get_downloader_view): * embed/ephy-embed-shell.h: * embed/ephy-embed-single.c: * embed/ephy-embed-single.h: * embed/mozilla/ProgressListener.cpp: * embed/mozilla/mozilla-embed.cpp: * lib/Makefile.am: * lib/ephy-langs.h: * lib/ephy-node.c: (unref_signal_objects), (ephy_node_signal_connect_object): * plugins/Makefile.am: * plugins/sample/Makefile.am: * plugins/sample/sample.c: (bmk_added), (bmk_removed), (bmk_changed), (switch_page_cb), (window_focus_in_cb), (location_changed_cb), (tab_added_cb), (new_window_cb), (plugin_init): * src/Makefile.am: * src/bookmarks/Makefile.am: * src/bookmarks/ephy-bookmark-action.c: (ephy_bookmark_action_sync_icon): * src/bookmarks/ephy-bookmark-properties.c: (set_window_icon), (ephy_bookmark_properties_init): * src/bookmarks/ephy-bookmarks-editor.c: (provide_favicon), (ephy_bookmarks_editor_init): * src/bookmarks/ephy-bookmarks.c: (update_favorites_menus): * src/bookmarks/ephy-topic-action.c: (build_bookmarks_menu): * src/ephy-automation.c: (impl_ephy_automation_loadurl), (impl_ephy_automation_quit), (impl_ephy_automation_load_session): * src/ephy-favicon-action.c: (ephy_favicon_action_init): * src/ephy-history-window.c: (confirmation_dialog_response_cb), (provide_favicon): * src/ephy-location-action.c: (connect_proxy): * src/ephy-notebook.c: (sync_icon): * src/ephy-shell.c: (ephy_shell_get_active_window), (ephy_shell_get_session), (ephy_shell_get_autocompletion), (ephy_shell_get_toolbars_model): * src/ephy-shell.h: * src/ephy-tab.c: (ephy_tab_net_state_cb), (ephy_tab_init), (ephy_tab_get_action): * src/ephy-tab.h: * src/ephy-tabs-menu.c: (ephy_tabs_menu_update): * src/ephy-window.c: (ephy_window_fullscreen), (ephy_window_unfullscreen), (sync_tab_icon), (ephy_window_init), (remove_from_session), (ephy_window_get_active_tab):
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f703d9124..dca04e6b8 100644
--- a/configure.in
+++ b/configure.in
@@ -3,6 +3,9 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(epiphany, 0.7.3,
[http://bugzilla.gnome.org/enter_bug.cgi?product=epiphany])
+EPIPHANY_MAJOR=1.0
+AC_SUBST(EPIPHANY_MAJOR)
+
AM_CONFIG_HEADER(config.h)
AC_CONFIG_SRCDIR(configure.in)
@@ -173,6 +176,15 @@ esac
AC_DEFINE_UNQUOTED(MOZILLA_SNAPSHOT, $MOZILLA_SNAPSHOT, [Define mozilla snapshot])
dnl *******************************
+dnl Plugins
+dnl *******************************
+
+AC_ARG_ENABLE(sample-plugin, [ --enable-sample-plugin (yes,no)
+ Enable sample plugin])
+AM_CONDITIONAL(ENABLE_SAMPLE_PLUGIN, test "x$enable_sample_plugin" = "xyes")
+
+
+dnl *******************************
dnl Internationalization
dnl *******************************
dnl Add the languages which your application supports here.