aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-10-31 02:06:54 +0800
committerChristian Persch <chpe@src.gnome.org>2004-10-31 02:06:54 +0800
commit7a1f9648b1e02d9da7a3c242cbe0e8d297b00c81 (patch)
tree1a2f69dcc13a9fcb749dd8f94292db369fccfabf /configure.in
parente4b9a0a0feb51f6be938b7368fc264d67d702553 (diff)
downloadgsoc2013-epiphany-7a1f9648b1e02d9da7a3c242cbe0e8d297b00c81.tar
gsoc2013-epiphany-7a1f9648b1e02d9da7a3c242cbe0e8d297b00c81.tar.gz
gsoc2013-epiphany-7a1f9648b1e02d9da7a3c242cbe0e8d297b00c81.tar.bz2
gsoc2013-epiphany-7a1f9648b1e02d9da7a3c242cbe0e8d297b00c81.tar.lz
gsoc2013-epiphany-7a1f9648b1e02d9da7a3c242cbe0e8d297b00c81.tar.xz
gsoc2013-epiphany-7a1f9648b1e02d9da7a3c242cbe0e8d297b00c81.tar.zst
gsoc2013-epiphany-7a1f9648b1e02d9da7a3c242cbe0e8d297b00c81.zip
Check for nsIDOMNSEvent::GetIsTrusted.
2004-10-30 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Check for nsIDOMNSEvent::GetIsTrusted. * embed/mozilla/EphyBrowser.cpp: Conditionally compile this code. * lib/ephy-marshal.list: Forgot to commit this.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0d851e949..d9f23bcea 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([GNOME Web browser], [1.4.4.90],
+AC_INIT([GNOME Web browser], [1.4.5],
[http://bugzilla.gnome.org/enter_bug.cgi?product=epiphany],[epiphany])
GNOME_COMMON_INIT
@@ -327,6 +327,21 @@ dnl changed from nsIXULChromeRegistry in 1.8a4
AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/chrome/nsIChromeRegistrySea.h],
[AC_DEFINE([HAVE_CHROME_NSICHROMEREGISTRYSEA_H], [1], [Define if nsIChromeRegistrySea.h exists])])
+dnl added after 1.7.3, on aviary and in 1.8a5 on trunk
+
+AC_MSG_CHECKING([for nsIDOMNSEvent::GetIsTrusted])
+
+AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [[#include <dom/nsIDOMNSEvent.h>]],
+ [[nsIDOMNSEvent *p;
+ p->GetIsTrusted (nsnull);]]
+ )],
+ [AC_DEFINE([MOZ_NSIDOMNSEVENT_GETISTRUSTED],[1],[dummy]) result=yes],
+ [result=no])
+
+AC_MSG_RESULT([$result])
+
dnl check for broken reload in GtkMozEmbed
dnl FIXME: I have NO IDEA how to do this. For now, just always enable our workaround
dnl