aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-11-20 04:15:25 +0800
committerChristian Persch <chpe@src.gnome.org>2004-11-20 04:15:25 +0800
commit1c4e8a38cd0d419cdb0f00ed9ee1b5a5063b2a72 (patch)
treebb77ea179f0eec843fbe2d2b99eee6151bf371f8 /configure.in
parent715b70c954ac694a0027039cea87bd33e0986679 (diff)
downloadgsoc2013-epiphany-1c4e8a38cd0d419cdb0f00ed9ee1b5a5063b2a72.tar
gsoc2013-epiphany-1c4e8a38cd0d419cdb0f00ed9ee1b5a5063b2a72.tar.gz
gsoc2013-epiphany-1c4e8a38cd0d419cdb0f00ed9ee1b5a5063b2a72.tar.bz2
gsoc2013-epiphany-1c4e8a38cd0d419cdb0f00ed9ee1b5a5063b2a72.tar.lz
gsoc2013-epiphany-1c4e8a38cd0d419cdb0f00ed9ee1b5a5063b2a72.tar.xz
gsoc2013-epiphany-1c4e8a38cd0d419cdb0f00ed9ee1b5a5063b2a72.tar.zst
gsoc2013-epiphany-1c4e8a38cd0d419cdb0f00ed9ee1b5a5063b2a72.zip
Add --disable-filepicker to use when the mozilla build itself has native
2004-11-19 Christian Persch <chpe@cvs.gnome.org> * configure.in: * embed/mozilla/Makefile.am: * embed/mozilla/MozRegisterComponents.cpp: Add --disable-filepicker to use when the mozilla build itself has native gtk+ filepicker.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 468f227bd..57c20175c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([GNOME Web browser], [1.4.5.90],
+AC_INIT([GNOME Web browser], [1.4.6],
[http://bugzilla.gnome.org/enter_bug.cgi?product=epiphany],[epiphany])
GNOME_COMMON_INIT
@@ -375,6 +375,18 @@ fi
MOZILLA_WARN_CXXFLAGS="-Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor"
AC_SUBST(MOZILLA_WARN_CXXFLAGS)
+AC_MSG_CHECKING([whether to enable native gtk+ filepicker])
+AC_ARG_ENABLE([filepicker],
+ AS_HELP_STRING([--enable-filepicker],[Whether to enable the gtk+ native filepicker; not neede when the mozilla build itself has native gtk+ filepicker enabled (default:enabled)]),
+ [filepicker=$enableval],
+ [filepicker=yes])
+AC_MSG_RESULT([$filepicker])
+
+AM_CONDITIONAL([ENABLE_FILEPICKER],[test "x$filepicker" = "xyes"])
+if test "x$filepicker" = "xyes"; then
+ AC_DEFINE([ENABLE_FILEPICKER],[1],[Define to enable the native filepicker])
+fi
+
dnl *******************************
dnl Internationalization
dnl *******************************