aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-08-28 04:55:44 +0800
committerChristian Persch <chpe@src.gnome.org>2004-08-28 04:55:44 +0800
commitf5ad5fbee402dc97a12541abdf66201a05b19c90 (patch)
tree3ab46effeb4e3ed298ae48582437359940ec33be /configure.in
parentb3bf299f39c5e20e256d97f66880616423cd804b (diff)
downloadgsoc2013-epiphany-f5ad5fbee402dc97a12541abdf66201a05b19c90.tar
gsoc2013-epiphany-f5ad5fbee402dc97a12541abdf66201a05b19c90.tar.gz
gsoc2013-epiphany-f5ad5fbee402dc97a12541abdf66201a05b19c90.tar.bz2
gsoc2013-epiphany-f5ad5fbee402dc97a12541abdf66201a05b19c90.tar.lz
gsoc2013-epiphany-f5ad5fbee402dc97a12541abdf66201a05b19c90.tar.xz
gsoc2013-epiphany-f5ad5fbee402dc97a12541abdf66201a05b19c90.tar.zst
gsoc2013-epiphany-f5ad5fbee402dc97a12541abdf66201a05b19c90.zip
Remove support for mozilla 1.8a2 too. Adapt to mozilla API change;
2004-08-27 Christian Persch <chpe@cvs.gnome.org> * configure.in: * embed/mozilla/ContentHandler.cpp: * embed/mozilla/EphyBrowser.cpp: * embed/mozilla/EphyContentPolicy.cpp: * embed/mozilla/FilePicker.cpp: * embed/mozilla/GlobalHistory.cpp: * embed/mozilla/GtkNSSKeyPairDialogs.cpp: * embed/mozilla/MozDownload.cpp: * embed/mozilla/mozilla-embed-single.cpp: Remove support for mozilla 1.8a2 too. Adapt to mozilla API change; re-number mozilla snapshots.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 9492189c0..eecbc358b 100644
--- a/configure.in
+++ b/configure.in
@@ -77,6 +77,7 @@ if test "x$enable_nautilus_view" = "xyes"; then
PKG_CHECK_MODULES(NAUTILUS_DEPENDENCY, libnautilus >= $LIBNAUTILUS_REQUIRED, \
[AC_DEFINE(ENABLE_NAUTILUS_VIEW, 1, [Define if the nautilus view has to be built])], \
[enable_nautilus_view=no])
+ AC_MSG_NOTICE([WARNING: nautilus view is deprecated and unsupported])
fi
AC_SUBST(NAUTILUS_DEPENDENCY_CFLAGS)
AC_SUBST(NAUTILUS_DEPENDENCY_LIBS)
@@ -185,8 +186,8 @@ MOZILLA_VERSION="`$PKG_CONFIG --modversion mozilla-gtkmozembed`"
dnl allow user to override the autodetected mozilla version
dnl - without arguments for cvs head
AC_ARG_WITH(mozilla-snapshot,
- AC_HELP_STRING([--with-mozilla-snapshot@<:@=1.4|1.4.1|1.4.2|1.5|1.5.1|1.6|1.7|1.7.1|1.7.2|1.8a2|trunk@:>@],
- [Whether to try building against mozilla 1.4|1.4.1|1.4.2|1.5|1.5.1|1.6|1.7|1.7.1|1.7.2|1.8a2|trunk
+ AC_HELP_STRING([--with-mozilla-snapshot@<:@=1.4|1.4.1|1.4.2|1.5|1.5.1|1.6|1.7|1.7.1|1.7.2|1.7.3|1.8a3|trunk@:>@],
+ [Whether to try building against mozilla 1.4|1.4.1|1.4.2|1.5|1.5.1|1.6|1.7|1.7.1|1.7.2|1.7.3|1.8a3|trunk
@<:@guessed@:>@]),
[autodetect=" (guessed: $MOZILLA_VERSION)"; MOZILLA_VERSION="$withval"])
@@ -197,18 +198,17 @@ case "$MOZILLA_VERSION" in
1.4.1) MOZILLA_SNAPSHOT=9 ;;
1.4.2) MOZILLA_SNAPSHOT=9 ;;
1.4.3) MOZILLA_SNAPSHOT=9 ;;
+1.4.4) MOZILLA_SNAPSHOT=9 ;;
1.5) MOZILLA_SNAPSHOT=11 ;;
1.5.1) MOZILLA_SNAPSHOT=11 ;;
1.6) MOZILLA_SNAPSHOT=13 ;;
1.7) MOZILLA_SNAPSHOT=17 ;;
1.7.1) MOZILLA_SNAPSHOT=17 ;;
1.7.2) MOZILLA_SNAPSHOT=17 ;;
-1.7.3) MOZILLA_SNAPSHOT=17 ;;
-1.7.4) MOZILLA_SNAPSHOT=17 ;;
-1.7.5) MOZILLA_SNAPSHOT=17 ;;
-branch1.7) MOZILLA_SNAPSHOT=17 ;;
-1.8a1) MOZILLA_SNAPSHOT=18 ;;
-1.8a2) MOZILLA_SNAPSHOT=19 ;;
+1.7.3) MOZILLA_SNAPSHOT=18 ;;
+1.7.4) MOZILLA_SNAPSHOT=18 ;;
+1.7.5) MOZILLA_SNAPSHOT=18 ;;
+branch1.7) MOZILLA_SNAPSHOT=18 ;;
1.8a3) MOZILLA_SNAPSHOT=20 ;;
1.8a4) MOZILLA_SNAPSHOT=21 ;;
1.8b) MOZILLA_SNAPSHOT=21 ;;
@@ -219,7 +219,7 @@ trunk) MOZILLA_SNAPSHOT=21 ;;
*) AC_ERROR([
*****************************************************************************
Epiphany can be built using Mozilla 1.4, 1.4.1, 1.4.2, 1.5, 1.5.1, 1.6, 1.7,
-1.7.1, 1.7.2, 1.8a2, 1.8a3, or trunk, but the version available is $MOZILLA_VERSION.
+1.7.1, 1.7.2, 1.7.3, 1.8a3, or trunk, but the version available is $MOZILLA_VERSION.
*****************************************************************************])
esac