aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2006-02-03 06:23:29 +0800
committerChristian Persch <chpe@src.gnome.org>2006-02-03 06:23:29 +0800
commitfd6923b630ae9629a99fa527baabb47d4454913a (patch)
tree1d79c86f348776dca510d6c219e3a441d6824f80 /configure.ac
parentee0fbb04172977f5c8076f4a99658c35eef645d4 (diff)
downloadgsoc2013-epiphany-fd6923b630ae9629a99fa527baabb47d4454913a.tar
gsoc2013-epiphany-fd6923b630ae9629a99fa527baabb47d4454913a.tar.gz
gsoc2013-epiphany-fd6923b630ae9629a99fa527baabb47d4454913a.tar.bz2
gsoc2013-epiphany-fd6923b630ae9629a99fa527baabb47d4454913a.tar.lz
gsoc2013-epiphany-fd6923b630ae9629a99fa527baabb47d4454913a.tar.xz
gsoc2013-epiphany-fd6923b630ae9629a99fa527baabb47d4454913a.tar.zst
gsoc2013-epiphany-fd6923b630ae9629a99fa527baabb47d4454913a.zip
Add GECKO_CHECK_HEADERS, wrapping AC_CHECK_HEADERS.
2006-02-02 Christian Persch <chpe@cvs.gnome.org> * m4/gecko.m4: Add GECKO_CHECK_HEADERS, wrapping AC_CHECK_HEADERS. * configure.ac: Simplify some header checks with GECKO_CHECK_HEADERS. Check for nsINonBlockingAlertService.h. * embed/mozilla/EphyPromptService.cpp: * embed/mozilla/EphyPromptService.h: * embed/mozilla/MozRegisterComponents.cpp: Implement nsINonBlockingAlertService.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 7 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 609b9cdab..308e85334 100644
--- a/configure.ac
+++ b/configure.ac
@@ -240,7 +240,7 @@ AC_MSG_RESULT([$result])
# changed from nsIXULChromeRegistry in 1.8a4
-AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/chrome/nsIChromeRegistrySea.h],
+GECKO_CHECK_HEADERS([],[chrome/nsIChromeRegistrySea.h],
[AC_DEFINE([HAVE_CHROME_NSICHROMEREGISTRYSEA_H], [1], [Define if nsIChromeRegistrySea.h exists])])
# changed location in 1.8a6
@@ -301,24 +301,8 @@ AM_CONDITIONAL([HAVE_MOZILLA_PSM],[test "$enable_psm" = "yes" -a "$have_psm" = "
# Not a simple file check due to the header being in the SDK since 1.8a6
# https://bugzilla.mozilla.org/show_bug.cgi?id=271068
-if test "$MOZILLA_FLAVOUR" = "mozilla"; then
- AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/nsIPassword.h],
- [AC_DEFINE([HAVE_NSIPASSWORD_H],[1],
- [Define if mozilla nsIPassword header is available])],
- [AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/wallet/nsIPassword.h],
- [AC_DEFINE([HAVE_NSIPASSWORD_H],[1],
- [Define if mozilla nsIPassword header is available]) have_password_h=yes])],
- [have_password_h=no])
-elif test "$MOZILLA_FLAVOUR" = "toolkit"; then
- AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/passwordmgr/nsIPassword.h],
- [AC_DEFINE([HAVE_NSIPASSWORD_H],[1],
- [Define if mozilla nsIPassword header is available]) have_password_h=yes],
- [have_password_h=no])
-fi
-
-if test "x$have_password_h" = "xno"; then
- AC_MSG_WARN([nsIPassword.h not found; personal data manger will have no passwords support!])
-fi
+GECKO_CHECK_HEADERS([passwordmgr wallet],[nsIPassword.h],
+ [],[AC_MSG_WARN([nsIPassword.h not found; personal data manger will have no passwords support!])])
# Check whether to enable our filepicker component
@@ -338,6 +322,10 @@ if test "x$enable_filepicker" = "xyes"; then
AC_DEFINE([ENABLE_FILEPICKER],[1],[Define to enable the native filepicker])
fi
+# Check for nsINonBlockingAlertService
+
+GECKO_CHECK_HEADERS([windowwatcher],[nsINonBlockingAlertService.h])
+
# Check for some contractIDs that we need but are provided by extensions
# which may or may not have been built.