aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-01-09 23:06:36 +0800
committerChristian Persch <chpe@src.gnome.org>2005-01-09 23:06:36 +0800
commitb0db89833c3973dd34b670fd40f0ca90a07766a7 (patch)
tree3a78c7aa8ddec7aa128970e6dfdab1779b429dc3 /configure.ac
parent0b5eddd9ee4966a0d4863a997acbf7a444bdfb77 (diff)
downloadgsoc2013-epiphany-b0db89833c3973dd34b670fd40f0ca90a07766a7.tar
gsoc2013-epiphany-b0db89833c3973dd34b670fd40f0ca90a07766a7.tar.gz
gsoc2013-epiphany-b0db89833c3973dd34b670fd40f0ca90a07766a7.tar.bz2
gsoc2013-epiphany-b0db89833c3973dd34b670fd40f0ca90a07766a7.tar.lz
gsoc2013-epiphany-b0db89833c3973dd34b670fd40f0ca90a07766a7.tar.xz
gsoc2013-epiphany-b0db89833c3973dd34b670fd40f0ca90a07766a7.tar.zst
gsoc2013-epiphany-b0db89833c3973dd34b670fd40f0ca90a07766a7.zip
Don't check for nsIBrowserHistory.
2005-01-09 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * embed/mozilla/GlobalHistory.cpp: Don't check for nsIBrowserHistory.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index e13e4b9e8..a68f3e98b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -335,12 +335,11 @@ AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
[[#include <nsIURI.h>
#include <nsIGlobalHistory.h>
- #include <docshell/nsIGlobalHistory2.h>
- #include <history/nsIBrowserHistory.h>]],
- [[nsIBrowserHistory *p;
+ #include <docshell/nsIGlobalHistory2.h>]],
+ [[nsIGlobalHistory2 *p;
p->AddURI(nsnull,PR_FALSE,PR_FALSE,nsnull);]]
)],
- [AC_DEFINE([MOZ_NSIBROWSERHISTORY_ADDURI_WITH_REFERRER],[1],[Define if nsIGlobalHistory2::AddURI takes a referrer]) result=yes],
+ [AC_DEFINE([MOZ_NSIGLOBALHISTORY2_ADDURI_WITH_REFERRER],[1],[Define if nsIGlobalHistory2::AddURI takes a referrer]) result=yes],
[result=no])
AC_MSG_RESULT([$result])