aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <cgarcia@igalia.com>2012-05-06 22:47:19 +0800
committerCarlos Garcia Campos <carlosgc@gnome.org>2012-06-21 19:54:16 +0800
commit97c91b2fc2059b1e358bb19896203afaa44bfd33 (patch)
tree6aa01250a99fa884d177ce3202d8ff41e8e96d74 /configure.ac
parenta8767266443074689200fff9ca43531d88d65aed (diff)
downloadgsoc2013-epiphany-97c91b2fc2059b1e358bb19896203afaa44bfd33.tar
gsoc2013-epiphany-97c91b2fc2059b1e358bb19896203afaa44bfd33.tar.gz
gsoc2013-epiphany-97c91b2fc2059b1e358bb19896203afaa44bfd33.tar.bz2
gsoc2013-epiphany-97c91b2fc2059b1e358bb19896203afaa44bfd33.tar.lz
gsoc2013-epiphany-97c91b2fc2059b1e358bb19896203afaa44bfd33.tar.xz
gsoc2013-epiphany-97c91b2fc2059b1e358bb19896203afaa44bfd33.tar.zst
gsoc2013-epiphany-97c91b2fc2059b1e358bb19896203afaa44bfd33.zip
Initial WebKit2 port
It builds and basic functionality works.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 21 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a1a9faf54..8aa2593ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,6 +90,18 @@ GNOME_KEYRING_REQUIRED=2.26.0
GSETTINGS_DESKTOP_SCHEMAS_REQUIRED=0.0.1
LIBNOTIFY_REQUIRED=0.5.1
+AC_ARG_WITH(webkit2,
+ [AC_HELP_STRING([--with-webkit2], [build with WebKit2 [default=no]])],
+ [],[with_webkit2=no])
+
+if test "x$with_webkit2" != xno; then
+ WEBKIT_GTK_PC_NAME=webkit2gtk-3.0
+ AC_DEFINE([HAVE_WEBKIT2],[1],[Define if building with WebKit2])
+else
+ WEBKIT_GTK_PC_NAME=webkitgtk-3.0
+fi
+AM_CONDITIONAL(WITH_WEBKIT2, test "x$with_webkit2" != xno)
+
# Tests
AC_MSG_CHECKING([whether to build tests])
@@ -112,7 +124,7 @@ PKG_CHECK_MODULES([DEPENDENCIES], [
sm
libxml-2.0 >= $LIBXML_REQUIRED
libxslt >= $LIBXSLT_REQUIRED
- webkitgtk-3.0 >= $WEBKIT_GTK_REQUIRED
+ $WEBKIT_GTK_PC_NAME >= $WEBKIT_GTK_REQUIRED
libsoup-gnome-2.4 >= $LIBSOUP_GNOME_REQUIRED
gnome-keyring-1 >= $GNOME_KEYRING_REQUIRED
gsettings-desktop-schemas >= $GSETTINGS_DESKTOP_SCHEMAS_REQUIRED
@@ -147,9 +159,13 @@ EPIPHANY_FEATURES=
GOBJECT_INTROSPECTION_CHECK([0.9.5])
-if test "$found_introspection" = "yes"; then
- EPIPHANY_FEATURES="$EPIPHANY_FEATURES introspection"
- AC_DEFINE([ENABLE_INTROSPECTION], [1], [Define to enable introspection support])
+if test "$with_webkit2" = "no"; then
+ if test "$found_introspection" = "yes"; then
+ EPIPHANY_FEATURES="$EPIPHANY_FEATURES introspection"
+ AC_DEFINE([ENABLE_INTROSPECTION], [1], [Define to enable introspection support])
+ fi
+else
+ found_introspection=no
fi
# ****
@@ -350,4 +366,5 @@ Epiphany was configured with the following options:
Seed support : $enable_seed
NSS support : $enable_nss
Build tests : $enable_tests
+ WebKit2 : $with_webkit2
"