aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-10-06 22:15:07 +0800
committerChristian Persch <chpe@src.gnome.org>2005-10-06 22:15:07 +0800
commit8f8805588ab31f3646fe8fb6e27191a962bc1eb8 (patch)
treef7f37db0103a242a7ccbede4cb4ddac3311f83b2 /configure.ac
parent2d2e6db37dcb70a1bbded7b7abf1e5c722f61f4a (diff)
downloadgsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.tar
gsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.tar.gz
gsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.tar.bz2
gsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.tar.lz
gsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.tar.xz
gsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.tar.zst
gsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.zip
Add "desktop-file" plugin, adapted from the "mozilla-desktop-file-plugin"
2005-10-06 Christian Persch <chpe@cvs.gnome.org> * Makefile.am: * configure.ac: * plugins/.cvsignore: * plugins/Makefile.am: * plugins/desktop-file/.cvsignore: * plugins/desktop-file/Makefile.am: * plugins/desktop-file/plugin.cpp: * po/POTFILES.in: Add "desktop-file" plugin, adapted from the "mozilla-desktop-file-plugin" written by Jorn Baayen <jbaayen@gnome.org>. For now only handle .desktop files from file:/// URIs, for security reasons.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a09dfb066..44d38648c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -639,6 +639,31 @@ AM_CONDITIONAL([ENABLE_PYTHON],[test "x$enable_python" = "xyes"])
AC_SUBST([EPIPHANY_FEATURES])
+dnl *******
+dnl Plugins
+dnl *******
+
+dnl Gecko 1.9 can handle .desktop files from file: URLs itself, so disable
+dnl this plugin at least until we handle non-file: URLs
+
+if test "$gecko_version_major" = "1" -a "$gecko_version_minor" -le "8"; then
+
+AC_MSG_CHECKING([whether to build the deskop file plugin])
+AC_ARG_ENABLE([desktop-file-plugin],
+ AS_HELP_STRING([--disable-desktop-file-plugin],[Disable the desktop file plugin (default: enabled)]),
+ [],[enable_desktop_file_plugin=yes])
+AC_MSG_RESULT([$enable_desktop_file_plugin])
+
+fi
+
+AM_CONDITIONAL([ENABLE_DESKTOP_FILE_PLUGIN],[test "x$enable_desktop_file_plugin" = "xyes"])
+
+if test "x$enable_desktop_file_plugin" = "xyes"; then
+ PKG_CHECK_MODULES([DESKTOP_FILE_PLUGIN_DEP],[$MOZILLA-xpcom $MOZILLA-plugin gtk+-2.0 >= 2.6.0])
+ AC_SUBST([DESKTOP_FILE_PLUGIN_DEP_CFLAGS])
+ AC_SUBST([DESKTOP_FILE_PLUGIN_DEP_LIBS])
+fi
+
dnl *******************
dnl Additional features
dnl *******************
@@ -740,6 +765,8 @@ embed/mozilla/Makefile
src/Makefile
src/bookmarks/Makefile
help/Makefile
+plugins/Makefile
+plugins/desktop-file/Makefile
po/Makefile.in
])