aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCyril Brulebois <cyrilbois@src.gnome.org>2007-11-07 04:19:12 +0800
committerCyril Brulebois <cyrilbois@src.gnome.org>2007-11-07 04:19:12 +0800
commit89a162f0b69c856e31d12350e1eb59935fd8e7ef (patch)
treeddc4133bf704427cc8b9c2833c5bd40c1fbe915f /configure.ac
parent77da5499bd2341cebf8e315478ec95432fa78765 (diff)
downloadgsoc2013-epiphany-89a162f0b69c856e31d12350e1eb59935fd8e7ef.tar
gsoc2013-epiphany-89a162f0b69c856e31d12350e1eb59935fd8e7ef.tar.gz
gsoc2013-epiphany-89a162f0b69c856e31d12350e1eb59935fd8e7ef.tar.bz2
gsoc2013-epiphany-89a162f0b69c856e31d12350e1eb59935fd8e7ef.tar.lz
gsoc2013-epiphany-89a162f0b69c856e31d12350e1eb59935fd8e7ef.tar.xz
gsoc2013-epiphany-89a162f0b69c856e31d12350e1eb59935fd8e7ef.tar.zst
gsoc2013-epiphany-89a162f0b69c856e31d12350e1eb59935fd8e7ef.zip
Enable a --with-distributor-name configure option, defaulting to Epiphany.
Use it on an error page to designate the distributors/developers to contact. Fixes bug #433796. svn path=/trunk/; revision=7643
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c62007af7..91b5cb647 100644
--- a/configure.ac
+++ b/configure.ac
@@ -789,6 +789,24 @@ if test "$have_gvfs" = "yes"; then
fi
AM_CONDITIONAL([HAVE_GVFS],[test "$have_gvfs" = "yes"])
+# Distributor name
+
+AC_ARG_WITH(distributor-name,
+[ --with-distributor-name=name Distributor name.],LSB_DISTRIBUTOR="$withval",)
+
+if test "x$LSB_DISTRIBUTOR" = "x"; then
+ AC_CHECK_PROGS([LSB_RELEASE], [lsb_release],)
+ if test -n "$LSB_RELEASE"; then
+ # Fallback on lsb_release if available
+ LSB_DISTRIBUTOR=$($LSB_RELEASE -i -s)
+ else
+ # Fallback on the product name
+ LSB_DISTRIBUTOR="Epiphany"
+ fi
+fi
+
+AC_DEFINE_UNQUOTED(LSB_DISTRIBUTOR, "$LSB_DISTRIBUTOR", [Distributor name.])
+
# compat cruft
GGE_VERSION=0
AC_SUBST([GGE_VERSION])