aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXan Lopez <xan@gnome.org>2009-12-26 01:55:48 +0800
committerXan Lopez <xan@gnome.org>2009-12-26 02:25:11 +0800
commit5ed79e7e20e53a2aa2e3ace40ebbb13584c09f2a (patch)
treece80d20269c776e8231bdd37eccf2bb52e3143cb /configure.ac
parent0b844bedb99264ae3699fb6a6aafa5e716b8c5ac (diff)
downloadgsoc2013-epiphany-5ed79e7e20e53a2aa2e3ace40ebbb13584c09f2a.tar
gsoc2013-epiphany-5ed79e7e20e53a2aa2e3ace40ebbb13584c09f2a.tar.gz
gsoc2013-epiphany-5ed79e7e20e53a2aa2e3ace40ebbb13584c09f2a.tar.bz2
gsoc2013-epiphany-5ed79e7e20e53a2aa2e3ace40ebbb13584c09f2a.tar.lz
gsoc2013-epiphany-5ed79e7e20e53a2aa2e3ace40ebbb13584c09f2a.tar.xz
gsoc2013-epiphany-5ed79e7e20e53a2aa2e3ace40ebbb13584c09f2a.tar.zst
gsoc2013-epiphany-5ed79e7e20e53a2aa2e3ace40ebbb13584c09f2a.zip
Use introspection.m4 file to detect introspection support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 7 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index f93880cfa..13423f04f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -215,40 +215,14 @@ EPIPHANY_FEATURES=
# GObject Introspection
# *********************
-AC_MSG_CHECKING([whether to enable GObject introspection support])
-AC_ARG_ENABLE([introspection],
- [AS_HELP_STRING([--enable-introspection],[Enable GObject introspection (default: disabled)])],
- [],[enable_introspection=no])
-AC_MSG_RESULT([$enable_introspection])
-
-G_IR_SCANNER=
-G_IR_COMPILER=
-G_IR_GENERATE=
-GIRDIR=
-GIRTYPELIBDIR=
-
-if test "$enable_introspection" = "yes"; then
- EPIPHANY_FEATURES="$EPIPHANY_FEATURES introspection"
-
- GOBJECT_INTROSPECTION_REQUIRED=0.6.2
- PKG_CHECK_MODULES([INTROSPECTION],[gobject-introspection-1.0 >= $GOBJECT_INTROSPECTION_REQUIRED])
-
- G_IR_SCANNER="$($PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0)"
- G_IR_COMPILER="$($PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0)"
- G_IR_GENERATE="$($PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0)"
- GIRDIR="$($PKG_CONFIG --variable=girdir gobject-introspection-1.0)"
- GIRTYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
+GOBJECT_INTROSPECTION_CHECK([0.6.7])
- AC_DEFINE([ENABLE_INTROSPECTION],[1],[Define to enable GObject introspection support])
+if test "$found_introspection" = "yes"; then
+ EPIPHANY_FEATURES="$EPIPHANY_FEATURES introspection"
+ AC_DEFINE([ENABLE_INTROSPECTION], [1], [Define to enable introspection support])
fi
-AC_SUBST([G_IR_SCANNER])
-AC_SUBST([G_IR_COMPILER])
-AC_SUBST([G_IR_GENERATE])
-AC_SUBST([GIRDIR])
-AC_SUBST([GIRTYPELIBDIR])
-
-AM_CONDITIONAL([ENABLE_INTROSPECTION],[test "$enable_introspection" = "yes"])
+AC_SUBST([EPIPHANY_FEATURES])
# ****
# Seed
@@ -260,7 +234,7 @@ AC_ARG_ENABLE([seed],
[],[enable_seed=no])
AC_MSG_RESULT([$enable_seed])
-if test "$enable_seed" = "yes" -a "$enable_introspection" != "yes"; then
+if test "$enable_seed" = "yes" -a "$found_introspection" != "yes"; then
AC_MSG_ERROR([GObject introspection support must be enabled for Seed])
fi
@@ -491,7 +465,7 @@ Epiphany was configured with the following options:
Zeroconf bookmarks support : $enable_zeroconf
NetworkManager support : $enable_network_manager
- GObject introspection : $enable_introspection
+ GObject introspection : $found_introspection
Seed support : $enable_seed
NSS support : $enable_nss
Build tests : $enable_tests