aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-10-31 02:04:40 +0800
committerChristian Persch <chpe@src.gnome.org>2004-10-31 02:04:40 +0800
commit4c41745e525a7fc35f29622e382ec7f881cc2e50 (patch)
tree20e3f974f518a22e7d9b00ed8075a0cf653e2f89 /configure.ac
parentebddd6104b96e1da09e8f6375ef7707ff42ee447 (diff)
downloadgsoc2013-epiphany-4c41745e525a7fc35f29622e382ec7f881cc2e50.tar
gsoc2013-epiphany-4c41745e525a7fc35f29622e382ec7f881cc2e50.tar.gz
gsoc2013-epiphany-4c41745e525a7fc35f29622e382ec7f881cc2e50.tar.bz2
gsoc2013-epiphany-4c41745e525a7fc35f29622e382ec7f881cc2e50.tar.lz
gsoc2013-epiphany-4c41745e525a7fc35f29622e382ec7f881cc2e50.tar.xz
gsoc2013-epiphany-4c41745e525a7fc35f29622e382ec7f881cc2e50.tar.zst
gsoc2013-epiphany-4c41745e525a7fc35f29622e382ec7f881cc2e50.zip
Check for nsIDOMNSEvent::GetIsTrusted.
2004-10-30 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Check for nsIDOMNSEvent::GetIsTrusted. * embed/mozilla/EphyBrowser.cpp: Conditionally compile this code. * lib/ephy-marshal.list: Forgot to commit this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c30027419..3bbbf53e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -344,6 +344,21 @@ dnl changed from nsIXULChromeRegistry in 1.8a4
AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/chrome/nsIChromeRegistrySea.h],
[AC_DEFINE([HAVE_CHROME_NSICHROMEREGISTRYSEA_H], [1], [Define if nsIChromeRegistrySea.h exists])])
+dnl added after 1.7.3, on aviary and in 1.8a5 on trunk
+
+AC_MSG_CHECKING([for nsIDOMNSEvent::GetIsTrusted])
+
+AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [[#include <dom/nsIDOMNSEvent.h>]],
+ [[nsIDOMNSEvent *p;
+ p->GetIsTrusted (nsnull);]]
+ )],
+ [AC_DEFINE([MOZ_NSIDOMNSEVENT_GETISTRUSTED],[1],[dummy]) result=yes],
+ [result=no])
+
+AC_MSG_RESULT([$result])
+
dnl check for broken reload in GtkMozEmbed
dnl FIXME: I have NO IDEA how to do this. For now, just always enable our workaround
dnl