aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJürg Billeter <j@bitron.ch>2005-07-24 05:31:19 +0800
committerChristian Persch <chpe@src.gnome.org>2005-07-24 05:31:19 +0800
commit057680fd0b25cc7bf90598f50bd2088ca4aa87ac (patch)
treef4580dd6c00b2707304b231a043502654e8aa4cd /configure.ac
parent7c8cd0db552da2366754cd7616e3ae9baec3b33a (diff)
downloadgsoc2013-epiphany-057680fd0b25cc7bf90598f50bd2088ca4aa87ac.tar
gsoc2013-epiphany-057680fd0b25cc7bf90598f50bd2088ca4aa87ac.tar.gz
gsoc2013-epiphany-057680fd0b25cc7bf90598f50bd2088ca4aa87ac.tar.bz2
gsoc2013-epiphany-057680fd0b25cc7bf90598f50bd2088ca4aa87ac.tar.lz
gsoc2013-epiphany-057680fd0b25cc7bf90598f50bd2088ca4aa87ac.tar.xz
gsoc2013-epiphany-057680fd0b25cc7bf90598f50bd2088ca4aa87ac.tar.zst
gsoc2013-epiphany-057680fd0b25cc7bf90598f50bd2088ca4aa87ac.zip
Use libgnomeprintui for the printing dialog and the paper part of the
2005-07-22 Jürg Billeter <j@bitron.ch> * configure.ac: * data/glade/print.glade: * embed/mozilla/EphyUtils.cpp: * embed/mozilla/EphyUtils.h: * embed/mozilla/PrintingPromptService.cpp: * embed/mozilla/PrintingPromptService.h: * embed/print-dialog.c: (ephy_print_info_free), (ephy_print_load_config_from_file), (ephy_print_save_config_to_file), (ephy_print_get_print_info), (ephy_print_dialog_response_cb), (ephy_print_do_print_idle_cb), (ephy_print_do_print_and_free), (ephy_print_paper_selector_new), (ephy_print_dialog_construct_range_page), (ephy_print_dialog_new), (ephy_print_setup_dialog_new): * embed/print-dialog.h: Use libgnomeprintui for the printing dialog and the paper part of the printing setup dialog. Fixes bug #141241, bug #163255 and bug #301730.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 03267baab..a64963a50 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,7 +28,7 @@ AC_CONFIG_SRCDIR([configure.ac])
EPIPHANY_MAJOR=1.7
AC_SUBST([EPIPHANY_MAJOR])
-AM_INIT_AUTOMAKE([dist-bzip2 no-dist-gzip check-news])
+AM_INIT_AUTOMAKE([1.8 dist-bzip2 no-dist-gzip check-news])
AM_MAINTAINER_MODE
if test "x$enable_maintainer_mode" = "xyes"; then
@@ -41,7 +41,7 @@ fi
AC_PROG_INTLTOOL([0.29])
-GLIB_REQUIRED=2.6.0
+GLIB_REQUIRED=2.7.0
PANGO_REQUIRED=1.8.0
GTK_REQUIRED=2.6.3
LIBXML_REQUIRED=2.6.12
@@ -51,6 +51,8 @@ LIBGNOMEVFS_REQUIRED=2.9.2
LIBGNOMEUI_REQUIRED=2.6.0
GNOME_DESKTOP_REQUIRED=2.9.91
LIBSTARTUP_NOTIFICATION_REQUIRED=0.5
+LIBGNOMEPRINT_REQUIRED=2.4.0
+LIBGNOMEPRINTUI_REQUIRED=2.4.0
AC_ENABLE_SHARED([yes])
AC_ENABLE_STATIC([no])
@@ -95,6 +97,8 @@ PKG_CHECK_MODULES([EPIPHANY_DEPENDENCY], [\
gconf-2.0 \
gnome-desktop-2.0 >= $GNOME_DESKTOP_REQUIRED \
$STARTUP_NOTIFICATION_PACKAGE \
+ libgnomeprint-2.2 >= $LIBGNOMEPRINT_REQUIRED \
+ libgnomeprintui-2.2 >= $LIBGNOMEPRINTUI_REQUIRED \
])
AC_SUBST([EPIPHANY_DEPENDENCY_CFLAGS])
AC_SUBST([EPIPHANY_DEPENDENCY_LIBS])