aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-11-08 06:41:03 +0800
committerChristian Persch <chpe@src.gnome.org>2005-11-08 06:41:03 +0800
commit003cc31d9db5de711c89915c916b77e9e910d59f (patch)
treefd4f06d1f6e30ad889378a9f87e8c7572b24e88a /configure.ac
parentb19e5ec32839085cb639d4fbbbe13b1d0526a2f7 (diff)
downloadgsoc2013-epiphany-003cc31d9db5de711c89915c916b77e9e910d59f.tar
gsoc2013-epiphany-003cc31d9db5de711c89915c916b77e9e910d59f.tar.gz
gsoc2013-epiphany-003cc31d9db5de711c89915c916b77e9e910d59f.tar.bz2
gsoc2013-epiphany-003cc31d9db5de711c89915c916b77e9e910d59f.tar.lz
gsoc2013-epiphany-003cc31d9db5de711c89915c916b77e9e910d59f.tar.xz
gsoc2013-epiphany-003cc31d9db5de711c89915c916b77e9e910d59f.tar.zst
gsoc2013-epiphany-003cc31d9db5de711c89915c916b77e9e910d59f.zip
Allow compilation against xulrunner. Patch by Robert O'Callahan
2005-11-07 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Allow compilation against xulrunner. Patch by Robert O'Callahan <rocallahan@novell.com>.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6e93fac69..200ce4441 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,10 +183,10 @@ dnl *******
AC_MSG_CHECKING([which gecko to use])
AC_ARG_WITH([mozilla],
- AS_HELP_STRING([--with-mozilla@<:@=mozilla|firefox|thunderbird@:>@],
+ AS_HELP_STRING([--with-mozilla@<:@=mozilla|firefox|xulrunner|thunderbird@:>@],
[Which gecko engine to use (default: autodetect)]))
-GECKOS="firefox mozilla-firefox seamonkey mozilla thunderbird mozilla-thunderbird"
+GECKOS="firefox mozilla-firefox seamonkey mozilla xulrunner thunderbird mozilla-thunderbird"
gecko=$with_mozilla
if test "x$gecko" = "x"; then
@@ -212,6 +212,7 @@ mozilla) min_version=1.7.9 flavour=mozilla ;;
seamonkey) min_version=1.0 flavour=mozilla ;;
*firefox) min_version=1.0.5 flavour=toolkit ;;
*thunderbird) min_version=1.0.5 flavour=toolkit ;;
+xulrunner) min_version=1.8 flavour=toolkit ;;
esac
MOZILLA=$gecko