aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2009-02-07 23:15:25 +0800
committerChristian Persch <chpe@src.gnome.org>2009-02-07 23:15:25 +0800
commita22e27e2fb1e351e99e28bc0f37fc292c4a8a860 (patch)
tree2a5b4ffe46b6e8139b23afd2b67dfc84956f0478 /configure.ac
parent2e720b50fa23e3045d0869ba09a4d6a005e9e14c (diff)
downloadgsoc2013-epiphany-a22e27e2fb1e351e99e28bc0f37fc292c4a8a860.tar
gsoc2013-epiphany-a22e27e2fb1e351e99e28bc0f37fc292c4a8a860.tar.gz
gsoc2013-epiphany-a22e27e2fb1e351e99e28bc0f37fc292c4a8a860.tar.bz2
gsoc2013-epiphany-a22e27e2fb1e351e99e28bc0f37fc292c4a8a860.tar.lz
gsoc2013-epiphany-a22e27e2fb1e351e99e28bc0f37fc292c4a8a860.tar.xz
gsoc2013-epiphany-a22e27e2fb1e351e99e28bc0f37fc292c4a8a860.tar.zst
gsoc2013-epiphany-a22e27e2fb1e351e99e28bc0f37fc292c4a8a860.zip
Fail if given --enable-seed without --enable-introspection.
svn path=/trunk/; revision=8757
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ef3c86338..6e9091abe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -262,6 +262,10 @@ AC_ARG_ENABLE([seed],
[],[enable_seed=no])
AC_MSG_RESULT([$enable_seed])
+if test "$enable_seed" = "yes" -a "$enable_introspection" != "yes"; then
+ AC_MSG_ERROR([GObject introspection support must be enabled for Seed])
+fi
+
if test "$enable_seed" = "yes"; then
EPIPHANY_FEATURES="$EPIPHANY_FEATURES seed"