aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2008-11-11 20:36:12 +0800
committerChristian Persch <chpe@src.gnome.org>2008-11-11 20:36:12 +0800
commit5e1461d192a1c1db2661d6fedb339837ed8e5fb2 (patch)
treed7f3cb5230764588954067314ce40eada08ce887 /configure.ac
parent0d171694caba5c8f01779c01fc0cdfdea4f120fa (diff)
downloadgsoc2013-epiphany-5e1461d192a1c1db2661d6fedb339837ed8e5fb2.tar
gsoc2013-epiphany-5e1461d192a1c1db2661d6fedb339837ed8e5fb2.tar.gz
gsoc2013-epiphany-5e1461d192a1c1db2661d6fedb339837ed8e5fb2.tar.bz2
gsoc2013-epiphany-5e1461d192a1c1db2661d6fedb339837ed8e5fb2.tar.lz
gsoc2013-epiphany-5e1461d192a1c1db2661d6fedb339837ed8e5fb2.tar.xz
gsoc2013-epiphany-5e1461d192a1c1db2661d6fedb339837ed8e5fb2.tar.zst
gsoc2013-epiphany-5e1461d192a1c1db2661d6fedb339837ed8e5fb2.zip
Remove libpython check that fails with libtool 2
svn path=/trunk/; revision=8608
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 0 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 0e0d22003..8930f2759 100644
--- a/configure.ac
+++ b/configure.ac
@@ -253,31 +253,6 @@ if test "$have_python" != "no"; then
AC_SUBST([PYTHON_LIB_LOC])
AC_SUBST([PYTHON_CFLAGS])
AC_SUBST([PYTHON_EXTRA_LIBS])
-
- # FIXME: do we really need this test?
- AC_MSG_CHECKING([whether we can build a shared library depending on libpython])
- rm -rf testpython
- mkdir testpython
- cd testpython
- cat > testpython.c <<EOF
-#include <Python.h>
-int testpython (void)
-{
-Py_Exit (0);
-}
-EOF
-
- if /bin/sh ../libtool --mode=compile ${CC} $PYTHON_CFLAGS -c testpython.c >/dev/null 2>&1 && \
- /bin/sh ../libtool --mode=link ${CC} -o testpython.la -rpath `pwd` -module -avoid-version $PYTHON_LIB_LOC testpython.lo $PYTHON_LIBS $PYTHON_EXTRA_LIBS >/dev/null 2>&1 && \
- grep 'dlname.*testpython' testpython.la >/dev/null 2>&1; then
- result=yes
- else
- result=no
- have_python=no
- fi
- cd ..
- rm -rf testpython
- AC_MSG_RESULT([$result])
fi
if test "$have_python" != "no"; then