aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-12-20 20:51:44 +0800
committerChristian Persch <chpe@src.gnome.org>2004-12-20 20:51:44 +0800
commit44d1914de33c38fb0f60e7088dc91491a1010d71 (patch)
treebe5943faac9dfe882620036e52018de30acab172 /configure.ac
parent9f0e94e176bea8b847b802b75d56403bce712b4c (diff)
downloadgsoc2013-epiphany-44d1914de33c38fb0f60e7088dc91491a1010d71.tar
gsoc2013-epiphany-44d1914de33c38fb0f60e7088dc91491a1010d71.tar.gz
gsoc2013-epiphany-44d1914de33c38fb0f60e7088dc91491a1010d71.tar.bz2
gsoc2013-epiphany-44d1914de33c38fb0f60e7088dc91491a1010d71.tar.lz
gsoc2013-epiphany-44d1914de33c38fb0f60e7088dc91491a1010d71.tar.xz
gsoc2013-epiphany-44d1914de33c38fb0f60e7088dc91491a1010d71.tar.zst
gsoc2013-epiphany-44d1914de33c38fb0f60e7088dc91491a1010d71.zip
Really make the configure check for -Wdeclaration-after-statement work.
2004-12-20 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Really make the configure check for -Wdeclaration-after-statement work.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ed1543191..ae1fceed0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,7 +142,9 @@ if test "x$enable_maintainer_mode" = "xyes"; then
AC_LANG_PUSH([C])
FLAGS="-Wdeclaration-after-statement"
_SAVE_AM_CFLAGS=$AM_CFLAGS
+ _SAVE_CFLAGS=$CFLAGS
AM_CFLAGS="$AM_CFLAGS $FLAGS"
+ CFLAGS="$CFLAGS $AM_CFLAGS"
AC_CACHE_CHECK([for compiler $FLAGS option],
ac_cv_have_declaration_after_statement,
@@ -156,6 +158,7 @@ if test "x$enable_maintainer_mode" = "xyes"; then
MORE_WARN_FLAGS="$MORE_WARN_FLAGS $FLAGS"
fi
AM_CFLAGS="$_SAVE_AM_CFLAGS"
+ CFLAGS="$_SAVE_CFLAGS"
AC_LANG_POP([C])
fi