aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-10-03 04:50:25 +0800
committerChristian Persch <chpe@src.gnome.org>2005-10-03 04:50:25 +0800
commitd7fea59666e1aaf5ecc97219538b79932173e135 (patch)
tree24a6c0522ec116d6d72e46a6d8fad6c74e4b429e /configure.ac
parentae8ea41f87ce8c1e69c6a9ebe03eb154fcbe22b3 (diff)
downloadgsoc2013-epiphany-d7fea59666e1aaf5ecc97219538b79932173e135.tar
gsoc2013-epiphany-d7fea59666e1aaf5ecc97219538b79932173e135.tar.gz
gsoc2013-epiphany-d7fea59666e1aaf5ecc97219538b79932173e135.tar.bz2
gsoc2013-epiphany-d7fea59666e1aaf5ecc97219538b79932173e135.tar.lz
gsoc2013-epiphany-d7fea59666e1aaf5ecc97219538b79932173e135.tar.xz
gsoc2013-epiphany-d7fea59666e1aaf5ecc97219538b79932173e135.tar.zst
gsoc2013-epiphany-d7fea59666e1aaf5ecc97219538b79932173e135.zip
Add configure switch to disable zeroconf bookmarks, since they're almost
2005-10-02 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * src/bookmarks/ephy-bookmarks.c: (save_filter), (ephy_bookmarks_save), (update_bookmark_keywords), (bookmark_is_categorized), (ephy_bookmarks_init), (ephy_bookmarks_finalize), (ephy_bookmarks_get_topic_uri), (ephy_bookmarks_find_keyword): * src/epiphany.defs: Add configure switch to disable zeroconf bookmarks, since they're almost useless since just about nobody ships gnome-vfs with howl support enabled, and have also been reported to cause long delays on startup.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fac05ca45..a09dfb066 100644
--- a/configure.ac
+++ b/configure.ac
@@ -639,6 +639,22 @@ AM_CONDITIONAL([ENABLE_PYTHON],[test "x$enable_python" = "xyes"])
AC_SUBST([EPIPHANY_FEATURES])
+dnl *******************
+dnl Additional features
+dnl *******************
+
+AC_MSG_CHECKING([whether to enable zeroconf bookmarks support])
+AC_ARG_ENABLE([zeroconf],
+ AS_HELP_STRING([--enable-zeroconf],[Whether to enable zeroconf bookmarks support (default:disabled)]),
+ [], [enable_zeroconf=no])
+AC_MSG_RESULT([$enable_zeroconf])
+
+if test "x$enable_zeroconf" = "xyes"; then
+ AC_DEFINE([ENABLE_ZEROCONF],[1],[Define to enable zeroconf bookmarks support])
+fi
+
+AM_CONDITIONAL([ENABLE_ZEROCONF],[test "x$enable_zeroconf" = "xyes"])
+
dnl *******************************
dnl Add warning flags
dnl *******************************