aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-01-06 04:48:47 +0800
committerChristian Persch <chpe@src.gnome.org>2005-01-06 04:48:47 +0800
commit1bb2458bbd832096bb10d850524c560129224b46 (patch)
tree88fc19b5bacfe02b7de2be652d7d265dc9f7c2c8 /configure.ac
parenta5d0e720fade615d0009a42d38b195a2db57b959 (diff)
downloadgsoc2013-epiphany-1bb2458bbd832096bb10d850524c560129224b46.tar
gsoc2013-epiphany-1bb2458bbd832096bb10d850524c560129224b46.tar.gz
gsoc2013-epiphany-1bb2458bbd832096bb10d850524c560129224b46.tar.bz2
gsoc2013-epiphany-1bb2458bbd832096bb10d850524c560129224b46.tar.lz
gsoc2013-epiphany-1bb2458bbd832096bb10d850524c560129224b46.tar.xz
gsoc2013-epiphany-1bb2458bbd832096bb10d850524c560129224b46.tar.zst
gsoc2013-epiphany-1bb2458bbd832096bb10d850524c560129224b46.zip
Only implement nsITransfer if possible.
2005-01-05 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * embed/mozilla/MozDownload.cpp: * embed/mozilla/MozDownload.h: Only implement nsITransfer if possible.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dcaea7d15..83f79150e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@ dnl You should have received a copy of the GNU General Public License along
dnl with this program; if not, write to the Free Software Foundation, Inc.,
dnl 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-AC_INIT([GNOME Web Browser],[1.5.3.90],[http://bugzilla.gnome.org/enter_bug.cgi?product=epiphany],[epiphany])
+AC_INIT([GNOME Web Browser],[1.5.4],[http://bugzilla.gnome.org/enter_bug.cgi?product=epiphany],[epiphany])
GNOME_COMMON_INIT
@@ -382,6 +382,7 @@ AC_MSG_RESULT([$result])
dnl Added in 1.8a6 on trunk
dnl https://bugzilla.mozilla.org/show_bug.cgi?id=223310
+
AC_MSG_CHECKING([whether nsIKeygenThread::StartKeyGeneration takes an nsIObserver])
AC_COMPILE_IFELSE(
@@ -413,6 +414,13 @@ AC_COMPILE_IFELSE(
AC_MSG_RESULT([$result])
+dnl exists since 1.8a6
+
+AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/nsITransfer.h],
+ [AC_DEFINE([HAVE_NSITRANSFER_H],[1],[Define if nsITransfer.h exists])],
+ [AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/uriloader/nsITransfer.h],
+ [AC_DEFINE([HAVE_NSITRANSFER_H],[1],[Define if nsITransfer.h exists])])])
+
dnl check for broken reload in GtkMozEmbed
dnl This is fixed since 1.7.4 on 1.7 branch, and since 1.8a3 on trunk