aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-05-21 22:42:45 +0800
committerChristian Persch <chpe@src.gnome.org>2005-05-21 22:42:45 +0800
commit042f31fbd699ec5125a2e05f02c82d9e6f015558 (patch)
tree1839572665d9728a2371f5056141e232a442450e /configure.ac
parent37e4cc15c39af9a10c7d0aaf46210c0d31db9e8e (diff)
downloadgsoc2013-epiphany-042f31fbd699ec5125a2e05f02c82d9e6f015558.tar
gsoc2013-epiphany-042f31fbd699ec5125a2e05f02c82d9e6f015558.tar.gz
gsoc2013-epiphany-042f31fbd699ec5125a2e05f02c82d9e6f015558.tar.bz2
gsoc2013-epiphany-042f31fbd699ec5125a2e05f02c82d9e6f015558.tar.lz
gsoc2013-epiphany-042f31fbd699ec5125a2e05f02c82d9e6f015558.tar.xz
gsoc2013-epiphany-042f31fbd699ec5125a2e05f02c82d9e6f015558.tar.zst
gsoc2013-epiphany-042f31fbd699ec5125a2e05f02c82d9e6f015558.zip
Add features variable to the .pc file, so we can check for python and dbus
2005-05-21 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * data/epiphany-1.8.pc.in: Add features variable to the .pc file, so we can check for python and dbus from epiphany-extensions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 73aaed8d2..f10333fc8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -424,6 +424,8 @@ dnl ****
dnl DBUS
dnl ****
+EPIPHANY_FEATURES=
+
AC_MSG_CHECKING([whether DBUS support is requested])
AC_ARG_ENABLE([dbus],
@@ -438,6 +440,7 @@ DBUS_GLIB_REQUIRED=0.22
if test "x$enable_dbus" = "xyes" ; then
AC_DEFINE([ENABLE_DBUS],[1],[Define if DBUS support is enabled])
+ EPIPHANY_FEATURES="$EPIPHANY_FEATURES dbus"
PKG_CHECK_MODULES([DBUS], [dbus-1 >= $DBUS_REQUIRED dbus-glib-1 >= $DBUS_GLIB_REQUIRED])
fi
@@ -558,9 +561,11 @@ if test "x$have_python" != "xyes"; then
elif test "x$enable_python" != "xno"; then
enable_python=yes
AC_DEFINE([ENABLE_PYTHON],[1],[Define to compile with python support])
+ EPIPHANY_FEATURES="$EPIPHANY_FEATURES python"
fi
AM_CONDITIONAL([ENABLE_PYTHON],[test "x$enable_python" = "xyes"])
+AC_SUBST([EPIPHANY_FEATURES])
dnl *******************************
dnl Add warning flags