aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-12-11 22:40:15 +0800
committerChristian Persch <chpe@src.gnome.org>2005-12-11 22:40:15 +0800
commitfbe31b361697275f1cf071d02ade300cf54e61a7 (patch)
tree9493efe263f5b9b16dbeb235db549b008e5f8ca9 /configure.ac
parentaabe93c2482f2371648e1e191d774ca127149ffa (diff)
downloadgsoc2013-epiphany-fbe31b361697275f1cf071d02ade300cf54e61a7.tar
gsoc2013-epiphany-fbe31b361697275f1cf071d02ade300cf54e61a7.tar.gz
gsoc2013-epiphany-fbe31b361697275f1cf071d02ade300cf54e61a7.tar.bz2
gsoc2013-epiphany-fbe31b361697275f1cf071d02ade300cf54e61a7.tar.lz
gsoc2013-epiphany-fbe31b361697275f1cf071d02ade300cf54e61a7.tar.xz
gsoc2013-epiphany-fbe31b361697275f1cf071d02ade300cf54e61a7.tar.zst
gsoc2013-epiphany-fbe31b361697275f1cf071d02ade300cf54e61a7.zip
A embed/ephy-certificate-manager.c: A embed/ephy-certificate-manager.h: A
2005-12-11 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * data/glade/Makefile.am: * data/glade/certs-manager.glade: * data/ui/epiphany-ui.xml: * embed/Makefile.am: A embed/ephy-certificate-manager.c: A embed/ephy-certificate-manager.h: A embed/ephy-x509-cert.c: A embed/ephy-x509-cert.h: * embed/mozilla/Makefile.am: * embed/mozilla/mozilla-embed-single.cpp: A embed/mozilla/mozilla-x509-cert.cpp: A embed/mozilla/mozilla-x509-cert.h: * src/Makefile.am: A src/ephy-certificate-manager.c: A src/ephy-certificate-manager.h: * src/ephy-window.c: * src/window-commands.c: * src/window-commands.h: Add certificate manager. Patch by Robert Marcano and Crispin Flowerday. Fixes bug #119090.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0f5a708c8..34886e01e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -531,6 +531,8 @@ fi
# Additional features
# *******************
+# Zeroconf bookmarks sites
+
AC_MSG_CHECKING([whether to enable zeroconf bookmarks support])
AC_ARG_ENABLE([zeroconf],
AS_HELP_STRING([--enable-zeroconf],[Whether to enable zeroconf bookmarks support (default:disabled)]),
@@ -543,6 +545,24 @@ fi
AM_CONDITIONAL([ENABLE_ZEROCONF],[test "x$enable_zeroconf" = "xyes"])
+# Certificates manager
+
+if test "$enable_psm" = "yes"; then
+
+AC_MSG_CHECKING([whether to build the certificates manager])
+AC_ARG_ENABLE([certificate-manager],
+ AS_HELP_STRING([--enable-certificate-manager],[Whether to enable the certificate manager (experimental; default:disabled)]),
+ [],[enable_certificate_manager=no])
+AC_MSG_RESULT([$enable_certificate_manager])
+
+fi
+
+if test "$enable_certificate_manager" = "yes"; then
+ AC_DEFINE([ENABLE_CERTIFICATE_MANAGER],[1],[Define to enable the certificate manager build])
+fi
+
+AM_CONDITIONAL([ENABLE_CERTIFICATE_MANAGER],[test "$enable_certificate_manager" = "yes"])
+
# *******************************
# Add warning flags
# *******************************