aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-11-09 20:19:58 +0800
committerChristian Persch <chpe@src.gnome.org>2004-11-09 20:19:58 +0800
commitaa0ae6239738f58c02c74dc403aa74fc6b4cb294 (patch)
treea8f654f2788e0e6a09cb42b309a3a2412c6505f6 /configure.ac
parentb3492a27945b00ab6ff7da81fefc313d838fce7e (diff)
downloadgsoc2013-epiphany-aa0ae6239738f58c02c74dc403aa74fc6b4cb294.tar
gsoc2013-epiphany-aa0ae6239738f58c02c74dc403aa74fc6b4cb294.tar.gz
gsoc2013-epiphany-aa0ae6239738f58c02c74dc403aa74fc6b4cb294.tar.bz2
gsoc2013-epiphany-aa0ae6239738f58c02c74dc403aa74fc6b4cb294.tar.lz
gsoc2013-epiphany-aa0ae6239738f58c02c74dc403aa74fc6b4cb294.tar.xz
gsoc2013-epiphany-aa0ae6239738f58c02c74dc403aa74fc6b4cb294.tar.zst
gsoc2013-epiphany-aa0ae6239738f58c02c74dc403aa74fc6b4cb294.zip
Fix check for nsIPassword.h header to look in the right place. Fixes bug
2004-11-09 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Fix check for nsIPassword.h header to look in the right place. Fixes bug #157743.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a458de625..3e9a5d57c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -381,9 +381,15 @@ AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/pipnss/nsIX509Cert.h],
[AC_DEFINE(HAVE_MOZILLA_PSM, 1,
[Define if you have the mozilla psm headers installed])])
-AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/nsIPassword.h],
- [AC_DEFINE(HAVE_NSIPASSWORD_H, 1,
- [Define if mozilla nsIPassword header is available])])
+if test "x$flavour" = "xmozilla"; then
+ AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/nsIPassword.h],
+ [AC_DEFINE(HAVE_NSIPASSWORD_H, 1,
+ [Define if mozilla nsIPassword header is available])])
+elif test "x$flavour" = "xtoolkit"; then
+ AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/passwordmgr/nsIPassword.h],
+ [AC_DEFINE(HAVE_NSIPASSWORD_H, 1,
+ [Define if mozilla nsIPassword header is available])])
+fi
MOZILLA_WARN_CXXFLAGS="-Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor"
AC_SUBST([MOZILLA_WARN_CXXFLAGS])