aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2008-08-15 03:41:56 +0800
committerChristian Persch <chpe@src.gnome.org>2008-08-15 03:41:56 +0800
commit93601ab889e0284f607b532921c59ea06f2785fa (patch)
treeb6b04a000a2a7bd5d1fe19100e4186ecf6f47f7c /configure.ac
parent3be63f81456440cad187fb7250e35c7158ebb6d9 (diff)
downloadgsoc2013-epiphany-93601ab889e0284f607b532921c59ea06f2785fa.tar
gsoc2013-epiphany-93601ab889e0284f607b532921c59ea06f2785fa.tar.gz
gsoc2013-epiphany-93601ab889e0284f607b532921c59ea06f2785fa.tar.bz2
gsoc2013-epiphany-93601ab889e0284f607b532921c59ea06f2785fa.tar.lz
gsoc2013-epiphany-93601ab889e0284f607b532921c59ea06f2785fa.tar.xz
gsoc2013-epiphany-93601ab889e0284f607b532921c59ea06f2785fa.tar.zst
gsoc2013-epiphany-93601ab889e0284f607b532921c59ea06f2785fa.zip
Allow remembering the selected user cert.
svn path=/branches/gnome-2-24/; revision=8417
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aa7ea6807..709d95a98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -390,6 +390,17 @@ GECKO_CHECK_HEADERS([spellchecker],[mozISpellCheckingEngine.h],
GECKO_CHECK_HEADERS([],[nsIBadCertListener.h],[have_nsibadcertlistener=yes],[have_nsibadcertlistener=no])
+# Check for nsIClientAuthUserDecision in nsIClientAuthDialogs.h
+
+GECKO_COMPILE_IFELSE([],
+ [GECKO_XPCOM_PROGRAM([[#include <nsIClientAuthDialogs.h>]],
+ [[nsIClientAuthUserDecision *decision;]])],
+ [have_nsIClientAuthUserDecision=yes],[have_nsIClientAuthUserDecision=no])
+
+if test "$have_nsIClientAuthUserDecision" = "yes"; then
+ AC_DEFINE([HAVE_NSICLIENTAUTHUSERDECISION],[1],[Define if nsIClientAuthUserDecision exists])
+fi
+
# Check for some contractIDs that we need but are provided by extensions
# which may or may not have been built.