aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-09-27 21:00:06 +0800
committerChristian Persch <chpe@src.gnome.org>2004-09-27 21:00:06 +0800
commit43e470f7461e38da9ec1894df5fbe619fb65ceb2 (patch)
tree8ecf47753fb6ffb3f1fc720a79aaeb641f23c258 /configure.ac
parent8656e7d44895631c82053c9630139015cb95ef57 (diff)
downloadgsoc2013-epiphany-43e470f7461e38da9ec1894df5fbe619fb65ceb2.tar
gsoc2013-epiphany-43e470f7461e38da9ec1894df5fbe619fb65ceb2.tar.gz
gsoc2013-epiphany-43e470f7461e38da9ec1894df5fbe619fb65ceb2.tar.bz2
gsoc2013-epiphany-43e470f7461e38da9ec1894df5fbe619fb65ceb2.tar.lz
gsoc2013-epiphany-43e470f7461e38da9ec1894df5fbe619fb65ceb2.tar.xz
gsoc2013-epiphany-43e470f7461e38da9ec1894df5fbe619fb65ceb2.tar.zst
gsoc2013-epiphany-43e470f7461e38da9ec1894df5fbe619fb65ceb2.zip
Improve configure check for DumpStackToFile to actually work.
2004-09-27 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Improve configure check for DumpStackToFile to actually work.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 4 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index c392c3044..a4abe0f9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -366,16 +366,10 @@ AC_MSG_RESULT([couldn't autodetect, assuming yes])
dnl check if mozilla's stack walker is accessible
-AC_MSG_CHECKING([for DumpStackToFile])
-
-AC_LINK_IFELSE(
- AC_LANG_PROGRAM(
- [[#include <stdio.h>]],
- [[extern void _Z15DumpStackToFileP8_IO_FILE (FILE *f);]]),
- [AC_DEFINE([HAVE_DUMPSTACKTOFILE], [1], [Define if DumpStackToFile is found]) result=yes],
- [result=no])
-
-AC_MSG_RESULT([$result])
+AC_CHECK_LIB([xpcom],[_Z15DumpStackToFileP8_IO_FILE],
+ [AC_DEFINE([HAVE_DUMPSTACKTOFILE], [1], [Define if DumpStackToFile is available]) result=yes],
+ [result=no],
+ [`pkg-config --libs $MOZILLA-xpcom`])
dnl restore flags
CXXFLAGS=$_SAVE_CXXFLAGS