aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2006-03-05 20:21:24 +0800
committerChristian Persch <chpe@src.gnome.org>2006-03-05 20:21:24 +0800
commit3a2bda9152fbe270dc271fe0992db7b206ed27cc (patch)
tree310bafe2291d8fbb091ab7eeb21218349840db8d /configure.ac
parent59b244b8258700f9d04a72f8e26bf8d26330f64c (diff)
downloadgsoc2013-epiphany-3a2bda9152fbe270dc271fe0992db7b206ed27cc.tar
gsoc2013-epiphany-3a2bda9152fbe270dc271fe0992db7b206ed27cc.tar.gz
gsoc2013-epiphany-3a2bda9152fbe270dc271fe0992db7b206ed27cc.tar.bz2
gsoc2013-epiphany-3a2bda9152fbe270dc271fe0992db7b206ed27cc.tar.lz
gsoc2013-epiphany-3a2bda9152fbe270dc271fe0992db7b206ed27cc.tar.xz
gsoc2013-epiphany-3a2bda9152fbe270dc271fe0992db7b206ed27cc.tar.zst
gsoc2013-epiphany-3a2bda9152fbe270dc271fe0992db7b206ed27cc.zip
Before running any test programs, check that we can compile and run any
2006-03-05 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * m4/gecko.m4: Before running any test programs, check that we can compile and run any XPCOM programs at all.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1061cefe7..44d5acfe6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -187,6 +187,11 @@ AC_SUBST([GECKO_LIBS])
# now tests for mozilla API variance
# **********************************
+# First build a test program to see whether compiling and running XPCOM
+# programs works at all, so we don't get false test failures below
+
+GECKO_XPCOM_PROGRAM_CHECK
+
# Changed from PRUnichar* to nsAString& in 1.8a1 and on aviary branch
AC_MSG_CHECKING([whether nsIFilePicker methods expect nsAString&])
@@ -344,9 +349,15 @@ if test "x$enable_filepicker" = "xyes"; then
fi
# Check for nsINonBlockingAlertService
+# Added in 1.8.1 and 1.9
GECKO_CHECK_HEADERS([windowwatcher],[nsINonBlockingAlertService.h])
+# Check for nsIGlobalHistory3
+# Added in 1.8.1 and 1.9
+
+GECKO_CHECK_HEADERS([docshell],[nsIGlobalHistory3.h])
+
# Check for some contractIDs that we need but are provided by extensions
# which may or may not have been built.
@@ -361,10 +372,6 @@ fi
GECKO_CHECK_CONTRACTIDS([$REQUIRED_CONTRACTS],
[],[AC_MSG_ERROR([$gecko_cv_gecko needs to be compiled with at least --enable-extensions=default,$REQUIRED_EXTENSIONS])])
-# Check for nsIGlobalHistory3
-
-GECKO_CHECK_HEADERS([docshell],[nsIGlobalHistory3.h])
-
# Needed since 1.8b2
# Define this down here so it doesn't affect the API checks above