aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2006-06-14 19:45:28 +0800
committerChristian Persch <chpe@src.gnome.org>2006-06-14 19:45:28 +0800
commit35e6a95adc793c85de4b2d78c6c4839ec167e37c (patch)
tree80667cc8b7c5390732be4ceacef105f325c8df22 /configure.ac
parent6807d5ea46c673bcc4378acc272eb487a26c0983 (diff)
downloadgsoc2013-epiphany-35e6a95adc793c85de4b2d78c6c4839ec167e37c.tar
gsoc2013-epiphany-35e6a95adc793c85de4b2d78c6c4839ec167e37c.tar.gz
gsoc2013-epiphany-35e6a95adc793c85de4b2d78c6c4839ec167e37c.tar.bz2
gsoc2013-epiphany-35e6a95adc793c85de4b2d78c6c4839ec167e37c.tar.lz
gsoc2013-epiphany-35e6a95adc793c85de4b2d78c6c4839ec167e37c.tar.xz
gsoc2013-epiphany-35e6a95adc793c85de4b2d78c6c4839ec167e37c.tar.zst
gsoc2013-epiphany-35e6a95adc793c85de4b2d78c6c4839ec167e37c.zip
Fix --disable-spell-checker configure option. Bug #344848.
2006-06-14 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Fix --disable-spell-checker configure option. Bug #344848.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac46
1 files changed, 27 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 379a2c66c..3243e9461 100644
--- a/configure.ac
+++ b/configure.ac
@@ -531,18 +531,21 @@ fi
AM_CONDITIONAL([ENABLE_NETWORK_MANAGER],[test "$enable_network_manager" = "yes"])
# Enchant spell checking
+# Does not appear to work on gecko 1.8.0, so only offer for >= 1.8.1
+if test "$gecko_cv_gecko_version_int" -ge "1008001"; then
+
+# Default to 'disabled' until it's fully functional
AC_MSG_CHECKING([whether spell checking support is requested])
AC_ARG_ENABLE([spell-checker],
AS_HELP_STRING([--enable-spell-checker],[Whether to enable spell checking using enchant]),
- [],
- [if test "$gecko_cv_gecko_version_int" -ge "1008001"; then
- enable_spell_checker=yes
- else
- enable_spell_checker="$have_gecko_spell_checker"
- fi])
+ [],[enable_spell_checker=no])
AC_MSG_RESULT([$enable_spell_checker])
+else
+ enable_spell_checker=no
+fi # gecko >= 1.8.1
+
if test "$enable_spell_checker" = "yes" -a "$have_gecko_spell_checker" != "yes"; then
AC_MSG_ERROR([Spell check support requested but $gecko_cv_gecko was not compiled with 'spellchecker' extension enabled.])
fi
@@ -660,16 +663,21 @@ AC_OUTPUT
# *************************************
# *************************************
-echo ""
-echo "Epiphany was configured with the following options:"
-echo ""
-echo "Gecko backend : $gecko_cv_gecko version $gecko_cv_gecko_version"
-echo "PSM support : $enable_psm"
-echo "Zeroconf bookmarks support : $enable_zeroconf"
-echo "NetworkManager support : $enable_network_manager"
-echo "Certificate manager : $enable_certificate_manager (experimental)"
-echo "Python support : $enable_python"
-echo "Desktop file plugin : $enable_desktop_file_plugin"
-echo "Spellchecker : $enable_spell_checker"
-echo "Debug mode : $enable_debug"
-echo ""
+echo "
+Epiphany was configured with the following options:
+
+ Source code location : $srcdir
+ Compiler : $CC
+ Prefix : $prefix
+ Extra debugging support : $enable_debug
+
+ Gecko backend : $gecko_cv_gecko version $gecko_cv_gecko_version
+ PSM support : $enable_psm
+ Zeroconf bookmarks support : $enable_zeroconf
+ NetworkManager support : $enable_network_manager
+ Certificate manager : $enable_certificate_manager (experimental)
+ Python support : $enable_python
+ Desktop file plugin : $enable_desktop_file_plugin
+ Spellchecker : $enable_spell_checker (experimental)
+
+"