aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-08-10 20:40:44 +0800
committerChristian Persch <chpe@src.gnome.org>2005-08-10 20:40:44 +0800
commit32c786666b663b1b1e63c70ffbfd0d232d47f59b (patch)
treec0ab9d1ccddc061219eaad6bcc4624d04744ac09 /configure.ac
parentdb0bea048019e077efcc954405336200dadbc6ff (diff)
downloadgsoc2013-epiphany-32c786666b663b1b1e63c70ffbfd0d232d47f59b.tar
gsoc2013-epiphany-32c786666b663b1b1e63c70ffbfd0d232d47f59b.tar.gz
gsoc2013-epiphany-32c786666b663b1b1e63c70ffbfd0d232d47f59b.tar.bz2
gsoc2013-epiphany-32c786666b663b1b1e63c70ffbfd0d232d47f59b.tar.lz
gsoc2013-epiphany-32c786666b663b1b1e63c70ffbfd0d232d47f59b.tar.xz
gsoc2013-epiphany-32c786666b663b1b1e63c70ffbfd0d232d47f59b.tar.zst
gsoc2013-epiphany-32c786666b663b1b1e63c70ffbfd0d232d47f59b.zip
Fix configure checks for focus workaround.
2005-08-10 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Fix configure checks for focus workaround.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0ca8fec43..8c180562e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -422,10 +422,12 @@ AC_LANG_POP([C++])
dnl Broken everywhere
dnl Provide a configure switch for easy testing of *real* fixes in gtkmozembed
+AC_MSG_CHECKING([whether to work around broken gtkmozembed focus])
AC_ARG_ENABLE([--enable-focus-fix],
- AS_HELP_STRING([focus-fix],[Enable the workaround for the broken GtkMozEmbed focus handling (default: enabled)])
+ AS_HELP_STRING([focus-fix],[Enable the workaround for the broken GtkMozEmbed focus handling (default: enabled)]),
[want_focus_fix=$enableval],
[want_focus_fix=yes])
+AC_MSG_RESULT([$want_focus_fix])
if test "x$want_focus_fix" = "xyes"; then
AC_DEFINE([GTKMOZEMBED_BROKEN_FOCUS],[1],[Define if GtkMozEmbed has broken focus handling])
@@ -437,10 +439,12 @@ dnl Define this down here so it doesn't affect the API checks above
AC_DEFINE([MOZILLA_INTERNAL_API],[1],[Define for access to internal mozilla API])
dnl Make sure we don't accidentally build without PSM support
+AC_MSG_CHECKING([whether to include PSM support])
AC_ARG_ENABLE([--disable-psm],
AS_HELP_STRING([psm],[Disable PSM support (default: enabled)]),
[want_psm=$enableval],
[want_psm=yes])
+AC_MSG_RESULT([$want_psm])
if test "x$want_psm" = "xyes" -a "x$have_psm" = "xno"; then
AC_MSG_ERROR([PSM headers not found; use --disable-psm to disable building with PSM support])