aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-08-08 04:31:32 +0800
committerChristian Persch <chpe@src.gnome.org>2005-08-08 04:31:32 +0800
commit250865f24a1a5fbcacf892cf014c6b0b85428ea2 (patch)
treebd01642b8b090b08fa532e2d45d68271e531ed40 /configure.ac
parentb04fefa6c0e46938090bd56cf9918748e1e48000 (diff)
downloadgsoc2013-epiphany-250865f24a1a5fbcacf892cf014c6b0b85428ea2.tar
gsoc2013-epiphany-250865f24a1a5fbcacf892cf014c6b0b85428ea2.tar.gz
gsoc2013-epiphany-250865f24a1a5fbcacf892cf014c6b0b85428ea2.tar.bz2
gsoc2013-epiphany-250865f24a1a5fbcacf892cf014c6b0b85428ea2.tar.lz
gsoc2013-epiphany-250865f24a1a5fbcacf892cf014c6b0b85428ea2.tar.xz
gsoc2013-epiphany-250865f24a1a5fbcacf892cf014c6b0b85428ea2.tar.zst
gsoc2013-epiphany-250865f24a1a5fbcacf892cf014c6b0b85428ea2.zip
Add switch to disable focus fix, and to disable PSM. Error out if PSM
2005-08-07 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Add switch to disable focus fix, and to disable PSM. Error out if PSM isn't found but --disable-psm not given. Should prevent accidental compilation without PSM. * lib/widgets/ephy-icon-entry.c: (ephy_icon_entry_get_entry): * lib/widgets/ephy-icon-entry.h: Add ephy_icon_entry_get_entry. * src/epiphany.defs: Updated python bindings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 22 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4ac173e36..f4cf9b0b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -391,7 +391,7 @@ AC_COMPILE_IFELSE(
[[nsIX509Cert *c;
c->GetIssuer (nsnull);]]
)],
- [AC_DEFINE([HAVE_MOZILLA_PSM], [1],[Define if you have the mozilla psm headers installed]) have_psm=yes],
+ [AC_DEFINE([HAVE_MOZILLA_PSM], [1],[Define if you have the mozilla NSS headers installed]) have_psm=yes],
[have_psm=no])
AC_MSG_RESULT([$have_psm])
@@ -420,14 +420,34 @@ CXXFLAGS=$_SAVE_CXXFLAGS
AC_LANG_POP([C++])
dnl Broken everywhere
+dnl Provide a configure switch for easy testing of *real* fixes in gtkmozembed
-AC_DEFINE([GTKMOZEMBED_BROKEN_FOCUS],[1],[Define if GtkMozEmbed has broken focus handling])
+AC_ARG_ENABLE([--enable-focus-fix],
+ AS_HELP_STRING([focus-fix],[Enable the workaround for the broken GtkMozEmbed focus handling (default: enabled)])
+ [want_focus_fix=$enableval],
+ [want_focus_fix=yes])
+
+if test "x$want_focus_fix" = "xyes"; then
+ AC_DEFINE([GTKMOZEMBED_BROKEN_FOCUS],[1],[Define if GtkMozEmbed has broken focus handling])
+fi
dnl Needed since 1.8b2
dnl Define this down here so it doesn't affect the API checks above
AC_DEFINE([MOZILLA_INTERNAL_API],[1],[Define for access to internal mozilla API])
+dnl Make sure we don't accidentally build without PSM support
+AC_ARG_ENABLE([--disable-psm],
+ AS_HELP_STRING([psm],[Disable PSM support (default: enabled)]),
+ [want_psm=$enableval],
+ [want_psm=yes])
+
+if test "x$want_psm" = "xyes" -a "x$have_psm" = "xno"; then
+ AC_MSG_ERROR([PSM headers not found; use --disable-psm to disable building with PSM support])
+elif test "x$have_psm" = "xno"; then
+ AC_MSG_WARN([PSM headers not found; PSM support disabled])
+fi
+
dnl Not a simple file check due to the header being in the SDK since 1.8a6
dnl https://bugzilla.mozilla.org/show_bug.cgi?id=271068