aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-08-10 20:47:43 +0800
committerChristian Persch <chpe@src.gnome.org>2005-08-10 20:47:43 +0800
commit21d8584587847a64e89820b0b8e77cad7a8e0fd4 (patch)
tree4ada529dfcc9390fa85b32086b820513a1cef73f /configure.ac
parent32c786666b663b1b1e63c70ffbfd0d232d47f59b (diff)
downloadgsoc2013-epiphany-21d8584587847a64e89820b0b8e77cad7a8e0fd4.tar
gsoc2013-epiphany-21d8584587847a64e89820b0b8e77cad7a8e0fd4.tar.gz
gsoc2013-epiphany-21d8584587847a64e89820b0b8e77cad7a8e0fd4.tar.bz2
gsoc2013-epiphany-21d8584587847a64e89820b0b8e77cad7a8e0fd4.tar.lz
gsoc2013-epiphany-21d8584587847a64e89820b0b8e77cad7a8e0fd4.tar.xz
gsoc2013-epiphany-21d8584587847a64e89820b0b8e77cad7a8e0fd4.tar.zst
gsoc2013-epiphany-21d8584587847a64e89820b0b8e77cad7a8e0fd4.zip
Warn if nsIPassword.h isn't found.
2005-08-10 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Warn if nsIPassword.h isn't found.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8c180562e..a06605fb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -439,6 +439,7 @@ dnl Define this down here so it doesn't affect the API checks above
AC_DEFINE([MOZILLA_INTERNAL_API],[1],[Define for access to internal mozilla API])
dnl Make sure we don't accidentally build without PSM support
+
AC_MSG_CHECKING([whether to include PSM support])
AC_ARG_ENABLE([--disable-psm],
AS_HELP_STRING([psm],[Disable PSM support (default: enabled)]),
@@ -461,13 +462,21 @@ if test "x$flavour" = "xmozilla"; then
[Define if mozilla nsIPassword header is available])],
[AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/wallet/nsIPassword.h],
[AC_DEFINE([HAVE_NSIPASSWORD_H],[1],
- [Define if mozilla nsIPassword header is available])])])
+ [Define if mozilla nsIPassword header is available]) have_password_h=yes])],
+ [have_password_h=no])
elif test "x$flavour" = "xtoolkit"; then
AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/passwordmgr/nsIPassword.h],
[AC_DEFINE([HAVE_NSIPASSWORD_H],[1],
- [Define if mozilla nsIPassword header is available])])
+ [Define if mozilla nsIPassword header is available]) have_password_h=yes],
+ [have_password_h=no])
+fi
+
+if test "x$have_password_h" = "xno"; then
+ AC_MSG_WARN([nsIPassword.h not found; personal data manger will have no passwords support!])
fi
+dnl Check whether to enable our filepicker component
+
AC_MSG_CHECKING([whether to enable native gtk+ filepicker])
AC_ARG_ENABLE([filepicker],
AS_HELP_STRING([--enable-filepicker],[Whether to enable the gtk+ native filepicker; not needed when the mozilla build itself has native gtk+ filepicker enabled (default:enabled)]),