aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-09-28 21:31:22 +0800
committerChristian Persch <chpe@src.gnome.org>2005-09-28 21:31:22 +0800
commit135b0e0d1f8dc462f7e5d9450609685352667186 (patch)
tree60194cac7bd87f349768af7cbfb0019814cb375c /configure.ac
parente117b8225e399cc1a57d5c8e63782251d6b44dae (diff)
downloadgsoc2013-epiphany-135b0e0d1f8dc462f7e5d9450609685352667186.tar
gsoc2013-epiphany-135b0e0d1f8dc462f7e5d9450609685352667186.tar.gz
gsoc2013-epiphany-135b0e0d1f8dc462f7e5d9450609685352667186.tar.bz2
gsoc2013-epiphany-135b0e0d1f8dc462f7e5d9450609685352667186.tar.lz
gsoc2013-epiphany-135b0e0d1f8dc462f7e5d9450609685352667186.tar.xz
gsoc2013-epiphany-135b0e0d1f8dc462f7e5d9450609685352667186.tar.zst
gsoc2013-epiphany-135b0e0d1f8dc462f7e5d9450609685352667186.zip
Hide the filters combo if there's only the "All" filter.
2005-09-28 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * embed/mozilla/FilePicker.cpp: Hide the filters combo if there's only the "All" filter.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 991c025fd..9a2180854 100644
--- a/configure.ac
+++ b/configure.ac
@@ -492,16 +492,16 @@ dnl Check whether to enable our filepicker component
AC_MSG_CHECKING([whether to enable native gtk+ filepicker])
AC_ARG_ENABLE([filepicker],
AS_HELP_STRING([--enable-filepicker],[Whether to enable the gtk+ native filepicker; not needed when the mozilla build itself has native gtk+ filepicker enabled (default:enabled)]),
- [filepicker=$enableval],
+ [],
[if test "$gecko_version_major" = "1" -a "$gecko_version_minor" -ge "8"; then
- filepicker=no
+ enable_filepicker=no
else
- filepicker=yes
+ enable_filepicker=yes
fi])
-AC_MSG_RESULT([$filepicker])
+AC_MSG_RESULT([$enable_filepicker])
-AM_CONDITIONAL([ENABLE_FILEPICKER],[test "x$filepicker" = "xyes"])
-if test "x$filepicker" = "xyes"; then
+AM_CONDITIONAL([ENABLE_FILEPICKER],[test "x$enable_filepicker" = "xyes"])
+if test "x$enable_filepicker" = "xyes"; then
AC_DEFINE([ENABLE_FILEPICKER],[1],[Define to enable the native filepicker])
fi