aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2007-09-20 02:07:53 +0800
committerChristian Persch <chpe@src.gnome.org>2007-09-20 02:07:53 +0800
commit010bcf7705bdbce88eb81b39c02fd95e4742d466 (patch)
tree741bc59c6149978b1e8549531c9045ee4ddc916c /configure.ac
parentb92fbf15e1841ea4d4e7cc70818d0a60a86f67f3 (diff)
downloadgsoc2013-epiphany-010bcf7705bdbce88eb81b39c02fd95e4742d466.tar
gsoc2013-epiphany-010bcf7705bdbce88eb81b39c02fd95e4742d466.tar.gz
gsoc2013-epiphany-010bcf7705bdbce88eb81b39c02fd95e4742d466.tar.bz2
gsoc2013-epiphany-010bcf7705bdbce88eb81b39c02fd95e4742d466.tar.lz
gsoc2013-epiphany-010bcf7705bdbce88eb81b39c02fd95e4742d466.tar.xz
gsoc2013-epiphany-010bcf7705bdbce88eb81b39c02fd95e4742d466.tar.zst
gsoc2013-epiphany-010bcf7705bdbce88eb81b39c02fd95e4742d466.zip
Add defines for major/minor/micro version.
Add SVN branch name, and use it in the ChangeLog generation rule. svn path=/trunk/; revision=7477
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 19 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c31510186..f148cbeea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,15 @@
# with this program; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
-AC_INIT([GNOME Web Browser],[2.21.0],[http://bugzilla.gnome.org/enter_bug.cgi?product=epiphany],[epiphany])
+m4_define([epiphany_version_major],[2])
+m4_define([epiphany_version_minor],[21])
+m4_define([epiphany_version_micro],[0])
+m4_define([epiphany_version],[epiphany_version_major.epiphany_version_minor.epiphany_version_micro])
+
+# This can be either "trunk" or "branches/gnome-x-y"
+m4_define([epiphany_branch],["trunk"])
+
+AC_INIT([GNOME Web Browser],[epiphany_version],[http://bugzilla.gnome.org/enter_bug.cgi?product=epiphany],[epiphany])
GNOME_COMMON_INIT
@@ -25,14 +33,13 @@ AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_SRCDIR([configure.ac])
-EPIPHANY_MAJOR=2.21
EPIPHANY_API_VERSION=2.21
# This should stay at the major version of the latest stable releases
EPIPHANY_UA_VERSION=2.20
-AC_SUBST([EPIPHANY_MAJOR])
-AC_SUBST([EPIPHANY_API_VERSION])
+AC_SUBST([EPIPHANY_MAJOR],[epiphany_version_major.epiphany_version_minor])
+AC_SUBST([EPIPHANY_API_VERSION],[epiphany_version_major.epiphany_version_minor])
AC_SUBST([EPIPHANY_UA_VERSION])
AM_INIT_AUTOMAKE([1.9 foreign dist-bzip2 no-dist-gzip tar-ustar])
@@ -717,6 +724,14 @@ AC_DEFINE_UNQUOTED([SHARE_UNINSTALLED_DIR], ["`pwd`/data"], [path to source data
GNOME_DOC_INIT
GTK_DOC_CHECK([1.0])
+# ****************************
+# SVN for ChangeLog generation
+# ****************************
+
+AC_SUBST([SVN_ROOT],[http://svn.gnome.org/svn])
+AC_SUBST([SVN_MODULE],[epiphany])
+AC_SUBST([SVN_BRANCH],[epiphany_branch])
+
# ************
# Output files
# ************