aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-02-27 06:01:48 +0800
committerChristian Persch <chpe@src.gnome.org>2005-02-27 06:01:48 +0800
commitfbf4b15ed54be3abfe2c3c937c50b9c623804cb5 (patch)
tree27639ff5895028fd04bcc8c4ce800354b040fa73 /configure.ac
parentcaba7f03132e463c48405eb602a8b77764c3ec75 (diff)
downloadgsoc2013-epiphany-fbf4b15ed54be3abfe2c3c937c50b9c623804cb5.tar
gsoc2013-epiphany-fbf4b15ed54be3abfe2c3c937c50b9c623804cb5.tar.gz
gsoc2013-epiphany-fbf4b15ed54be3abfe2c3c937c50b9c623804cb5.tar.bz2
gsoc2013-epiphany-fbf4b15ed54be3abfe2c3c937c50b9c623804cb5.tar.lz
gsoc2013-epiphany-fbf4b15ed54be3abfe2c3c937c50b9c623804cb5.tar.xz
gsoc2013-epiphany-fbf4b15ed54be3abfe2c3c937c50b9c623804cb5.tar.zst
gsoc2013-epiphany-fbf4b15ed54be3abfe2c3c937c50b9c623804cb5.zip
Depend on gnome-desktop for gnome-desktop-item, and up the gnome-vfs
2005-02-26 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Depend on gnome-desktop for gnome-desktop-item, and up the gnome-vfs dependency version. * embed/ephy-embed-persist.c: (ephy_embed_persist_set_user_time), (ephy_embed_persist_get_user_time), (ephy_embed_persist_set_property), (ephy_embed_persist_get_property), (ephy_embed_persist_init), (ephy_embed_persist_class_init): * embed/ephy-embed-persist.h: Add user time property. * embed/mozilla/ContentHandler.cpp: * embed/mozilla/ContentHandler.h: Forward user time to MozDownload via a string. Not perfect, but better than nothing. * embed/mozilla/EphyHeaderSniffer.cpp: Set user time on filechooser. * embed/mozilla/MozDownload.cpp: Get user time from content handler, and use it when launching the external handler app. * lib/ephy-file-helpers.c: (ephy_file_check_mime), (launch_desktop_item), (ephy_file_launch_desktop_file), (ephy_file_launch_application), (ephy_file_launch_handler): * lib/ephy-file-helpers.h: Convenience functions to launch an app, or a desktop item, with user time. * lib/ephy-gui.c: (ephy_gui_confirm_overwrite_file), (ephy_gui_window_update_user_time), (ephy_gui_window_present): * lib/ephy-gui.h: Make our own gtk_window_present, to correctly update user time. Check if the path is writable in ephy_gui_confirm_overwrite_file(). * src/ephy-session.c: (ephy_session_autoresume): After showing the recovery dialogue, don't use the old user time to launch the windows; use the current event time instead. * src/popup-commands.c: (background_download_completed), (image_open_uri), (save_source_completed_cb), (popup_cmd_open_image): * src/window-commands.c: (window_cmd_file_save_as), (save_source_completed_cb), (save_temp_source), (window_cmd_view_page_source): Launch handlers with user time.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 4527232c2..c32e89793 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,10 +48,10 @@ PANGO_REQUIRED=1.8.0
GTK_REQUIRED=2.6.0
LIBXML_REQUIRED=2.6.12
LIBXSLT_REQUIRED=1.1.7
-LIBGNOMEVFS_REQUIRED=2.3.1
LIBGLADE_REQUIRED=2.3.1
+LIBGNOMEVFS_REQUIRED=2.9.2
LIBGNOMEUI_REQUIRED=2.6.0
-GNOME_ICON_THEME_REQUIRED=2.9.90
+GNOME_DESKTOP_REQUIRED=2.9.91
AC_ENABLE_SHARED([yes])
AC_ENABLE_STATIC([no])
@@ -68,7 +68,7 @@ AC_PATH_PROG([GLIB_GENMARSHAL], [glib-genmarshal])
AC_PATH_PROG([GLIB_MKENUMS],[glib-mkenums])
GNOME_DEBUG_CHECK
-GNOME_COMPILE_WARNINGS([error])
+GNOME_COMPILE_WARNINGS([maximum])
dnl GNOME_CXX_WARNINGS
PKG_CHECK_MODULES([EPIPHANY_DEPENDENCY], [\
@@ -85,7 +85,7 @@ PKG_CHECK_MODULES([EPIPHANY_DEPENDENCY], [\
gnome-vfs-2.0 >= $LIBGNOMEVFS_REQUIRED \
gnome-vfs-module-2.0 \
gconf-2.0 \
- gnome-icon-theme >= $GNOME_ICON_THEME_REQUIRED \
+ gnome-desktop-2.0 >= $GNOME_DESKTOP_REQUIRED \
])
AC_SUBST([EPIPHANY_DEPENDENCY_CFLAGS])
AC_SUBST([EPIPHANY_DEPENDENCY_LIBS])