aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-11-20 04:13:44 +0800
committerChristian Persch <chpe@src.gnome.org>2004-11-20 04:13:44 +0800
commitb0e668237680c11a5e3189d367ea1dbc7544d130 (patch)
treee1414d4016b9712fa5c5415ffc3b8b2404fc5c45 /configure.ac
parentc98367a38ddb3af23365caa49a0684e7ba7750ef (diff)
downloadgsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.tar
gsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.tar.gz
gsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.tar.bz2
gsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.tar.lz
gsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.tar.xz
gsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.tar.zst
gsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.zip
Add --disable-filepicker to use when the mozilla build itself has native
2004-11-19 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * embed/mozilla/Makefile.am: * embed/mozilla/MozRegisterComponents.cpp: Add --disable-filepicker to use when the mozilla build itself has native gtk+ filepicker.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f53df1038..1a4fd85c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -394,6 +394,18 @@ fi
MOZILLA_WARN_CXXFLAGS="-Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor"
AC_SUBST([MOZILLA_WARN_CXXFLAGS])
+AC_MSG_CHECKING([whether to enable native gtk+ filepicker])
+AC_ARG_ENABLE([filepicker],
+ AS_HELP_STRING([--enable-filepicker],[Whether to enable the gtk+ native filepicker; not neede when the mozilla build itself has native gtk+ filepicker enabled (default:enabled)]),
+ [filepicker=$enableval],
+ [filepicker=yes])
+AC_MSG_RESULT([$filepicker])
+
+AM_CONDITIONAL([ENABLE_FILEPICKER],[test "x$filepicker" = "xyes"])
+if test "x$filepicker" = "xyes"; then
+ AC_DEFINE([ENABLE_FILEPICKER],[1],[Define to enable the native filepicker])
+fi
+
dnl *******************************
dnl Internationalization
dnl *******************************