aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-01-02 04:54:18 +0800
committerChristian Persch <chpe@src.gnome.org>2005-01-02 04:54:18 +0800
commit478e8b73f9a7302f0c30aaa685fc3104b99d7480 (patch)
tree4f800d05da81b03483afa46144e147510aa1503b /configure.ac
parentd8ef21e4e64809d0c244c6b68701505807620569 (diff)
downloadgsoc2013-epiphany-478e8b73f9a7302f0c30aaa685fc3104b99d7480.tar
gsoc2013-epiphany-478e8b73f9a7302f0c30aaa685fc3104b99d7480.tar.gz
gsoc2013-epiphany-478e8b73f9a7302f0c30aaa685fc3104b99d7480.tar.bz2
gsoc2013-epiphany-478e8b73f9a7302f0c30aaa685fc3104b99d7480.tar.lz
gsoc2013-epiphany-478e8b73f9a7302f0c30aaa685fc3104b99d7480.tar.xz
gsoc2013-epiphany-478e8b73f9a7302f0c30aaa685fc3104b99d7480.tar.zst
gsoc2013-epiphany-478e8b73f9a7302f0c30aaa685fc3104b99d7480.zip
We don't need to implement nsIBrowserHistory.
2005-01-01 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * embed/mozilla/GlobalHistory.cpp: * embed/mozilla/GlobalHistory.h: We don't need to implement nsIBrowserHistory.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 0 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index 583f6ea85..dcaea7d15 100644
--- a/configure.ac
+++ b/configure.ac
@@ -326,44 +326,6 @@ AC_DEFINE_UNQUOTED([MOZ_NSICONTENTPOLICY_VARIANT], [$variant], [Define the nsICo
AC_MSG_RESULT([variant $variant])
-dnl Changed from char* to nsIURI* in 1.7.4 on 1.7 branch,
-dnl in 1.8a3 on trunk and on aviary branch
-
-AC_MSG_CHECKING([whether nsIBrowserHistory methods expect nsIURI*])
-
-AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM(
- [[#include <nsIURI.h>
- #include <nsIGlobalHistory.h>
- #include <docshell/nsIGlobalHistory2.h>
- #include <history/nsIBrowserHistory.h>]],
- [[nsIBrowserHistory* p;
- nsIURI *arg1;
- p->RemovePage(arg1);]]
- )],
- [AC_DEFINE([MOZ_NSIGLOBALHISTORY_NSIURIP],[1],[Define if nsIBrowserHistory methods expect nsIURI*]) result=yes],
- [result=no])
-
-AC_MSG_RESULT([$result])
-
-dnl This is only present in new-toolkit apps
-
-AC_MSG_CHECKING([for nsIBrowserHistory::AddPageWithDetails])
-
-AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM(
- [[#include <nsIURI.h>
- #include <nsIGlobalHistory.h>
- #include <docshell/nsIGlobalHistory2.h>
- #include <history/nsIBrowserHistory.h>]],
- [[nsIBrowserHistory *p;
- p->AddPageWithDetails(nsnull,nsnull,0);]]
- )],
- [AC_DEFINE([MOZ_NSIBROWSERHISTORY_ADDPAGEWITHDETAILS],[1],[Define if nsIBrowserHistory::AddPageWithDetails exists]) result=yes],
- [result=no])
-
-AC_MSG_RESULT([$result])
-
dnl changed in 1.8a4
AC_MSG_CHECKING([for whether nsIGlobalHistory2::AddURI takes a referrer])