aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-04-06 22:29:55 +0800
committerChristian Persch <chpe@src.gnome.org>2005-04-06 22:29:55 +0800
commitd4c3f7dbac768d26ac755ed20cd0d6fe0d1e7be3 (patch)
treeaaa58108307c134edd4a2d19545c37d2252cb599 /configure.ac
parent7057c3852b199c8d523233c4e669acfae1246709 (diff)
downloadgsoc2013-epiphany-d4c3f7dbac768d26ac755ed20cd0d6fe0d1e7be3.tar
gsoc2013-epiphany-d4c3f7dbac768d26ac755ed20cd0d6fe0d1e7be3.tar.gz
gsoc2013-epiphany-d4c3f7dbac768d26ac755ed20cd0d6fe0d1e7be3.tar.bz2
gsoc2013-epiphany-d4c3f7dbac768d26ac755ed20cd0d6fe0d1e7be3.tar.lz
gsoc2013-epiphany-d4c3f7dbac768d26ac755ed20cd0d6fe0d1e7be3.tar.xz
gsoc2013-epiphany-d4c3f7dbac768d26ac755ed20cd0d6fe0d1e7be3.tar.zst
gsoc2013-epiphany-d4c3f7dbac768d26ac755ed20cd0d6fe0d1e7be3.zip
Fix for MOZILLA_INTERNAL_API change, and for 64bit downloader change.
2005-04-06 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * embed/downloader-view.c: (update_download_row): * embed/ephy-download.c: * embed/ephy-download.h: * embed/ephy-embed-persist.c: (ephy_embed_persist_set_max_size), (ephy_embed_persist_set_property), (ephy_embed_persist_get_property), (ephy_embed_persist_class_init): * embed/ephy-embed-persist.h: * embed/mozilla/ContentHandler.h: * embed/mozilla/EphyBrowser.cpp: * embed/mozilla/EphyContentPolicy.cpp: * embed/mozilla/EphyHeaderSniffer.h: * embed/mozilla/EphyHistoryListener.cpp: * embed/mozilla/EphySidebar.cpp: * embed/mozilla/EphySingle.cpp: * embed/mozilla/EphyUtils.cpp: * embed/mozilla/EventContext.cpp: * embed/mozilla/FilePicker.cpp: * embed/mozilla/FilePicker.h: * embed/mozilla/GlobalHistory.cpp: * embed/mozilla/GtkNSSClientAuthDialogs.cpp: * embed/mozilla/GtkNSSDialogs.cpp: * embed/mozilla/MozDownload.cpp: * embed/mozilla/MozDownload.h: * embed/mozilla/mozilla-download.cpp: * embed/mozilla/mozilla-embed-single.cpp: * embed/mozilla/mozilla-embed.cpp: Fix for MOZILLA_INTERNAL_API change, and for 64bit downloader change.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index da675d6fe..8c4e570f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -260,7 +260,7 @@ dnl **********************************
dnl FIXME find a m4/autoconf guru who can distill this into a nice macro
-CPPFLAGS="-I$MOZILLA_INCLUDE_ROOT -I$MOZILLA_INCLUDE_ROOT/pipnss `$PKG_CONFIG --cflags-only-I $MOZILLA-xpcom` -DMOZILLA_STRICT_API"
+CPPFLAGS="-I$MOZILLA_INCLUDE_ROOT -I$MOZILLA_INCLUDE_ROOT/pipnss `$PKG_CONFIG --cflags-only-I $MOZILLA-xpcom`"
CXXFLAGS="$_SAVE_CXXFLAGS $AM_CXXFLAGS `$PKG_CONFIG --cflags-only-other $MOZILLA-xpcom`"
AC_MSG_CHECKING([[whether we have a gtk 2 mozilla build]])
@@ -498,6 +498,11 @@ CXXFLAGS=$_SAVE_CXXFLAGS
AC_LANG_POP([C++])
+dnl Needed since 1.8b2
+dnl Define this down here so it doesn't affect the API checks above
+
+AC_DEFINE([MOZILLA_INTERNAL_API],[1],[Define for access to internal mozilla API])
+
dnl Not a simple file check due to the header being in the SDK since 1.8a6
dnl https://bugzilla.mozilla.org/show_bug.cgi?id=271068