aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-05-29 05:58:47 +0800
committerChristian Persch <chpe@src.gnome.org>2005-05-29 05:58:47 +0800
commitd0cc3530df347aed28b20fb884321a42b1b1958d (patch)
treeec070c45a016178c79322d426114bcde3b596ce6 /configure.ac
parent995f6539fb26444a0496b6311fecdbe9ad9cc8ff (diff)
downloadgsoc2013-epiphany-d0cc3530df347aed28b20fb884321a42b1b1958d.tar
gsoc2013-epiphany-d0cc3530df347aed28b20fb884321a42b1b1958d.tar.gz
gsoc2013-epiphany-d0cc3530df347aed28b20fb884321a42b1b1958d.tar.bz2
gsoc2013-epiphany-d0cc3530df347aed28b20fb884321a42b1b1958d.tar.lz
gsoc2013-epiphany-d0cc3530df347aed28b20fb884321a42b1b1958d.tar.xz
gsoc2013-epiphany-d0cc3530df347aed28b20fb884321a42b1b1958d.tar.zst
gsoc2013-epiphany-d0cc3530df347aed28b20fb884321a42b1b1958d.zip
Check for toolkit nsITypeAheadFind.
2005-05-28 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Check for toolkit nsITypeAheadFind. * embed/Makefile.am: * embed/ephy-embed-factory.c: (ephy_embed_factory_new_object): * embed/ephy-embed-find.c: (ephy_embed_find_set_embed), (ephy_embed_find_set_properties), (ephy_embed_find_find), (ephy_embed_find_find_again), (ephy_embed_find_get_type): * embed/ephy-embed-find.h: * embed/ephy-embed.c: * embed/ephy-embed.h: * embed/mozilla/EphyBrowser.cpp: * embed/mozilla/EphyBrowser.h: * embed/mozilla/EphyFind.cpp: * embed/mozilla/EphyFind.h: * embed/mozilla/Makefile.am: * embed/mozilla/mozilla-embed-find.cpp: * embed/mozilla/mozilla-embed-find.h: * embed/mozilla/mozilla-embed.cpp: * src/bookmarks/ephy-bookmarks-import.c: (gul_general_read_line_from_file): * src/ephy-find-toolbar.c: (get_find), (set_controls), (tab_content_changed_cb), (entry_changed_cb), (ephy_find_toolbar_init), (ephy_find_toolbar_finalize), (ephy_find_toolbar_class_init), (ephy_find_toolbar_new), (ephy_find_toolbar_get_text), (ephy_find_toolbar_set_embed), (ephy_find_toolbar_find_next), (ephy_find_toolbar_find_previous): * src/ephy-find-toolbar.h: * src/ephy-window.c: (ephy_window_set_active_tab), (ephy_window_init), (ephy_window_get_find_toolbar), (ephy_window_notebook_switch_page_cb): * src/ephy-window.h: * src/window-commands.c: (window_cmd_edit_find_next), (window_cmd_edit_find_prev): Implement typeaheadfind for the find toolbar.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d17dc2b70..e53aa02ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -390,6 +390,21 @@ AC_MSG_RESULT([$have_psm])
AM_CONDITIONAL([HAVE_MOZILLA_PSM],[test "x$have_psm" = "xyes"])
+dnl This is only present on toolkit
+
+AC_MSG_CHECKING([for toolkit's nsITypeAheadFind])
+
+AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [[#include <fastfind/nsITypeAheadFind.h>]],
+ [[nsITypeAheadFind *p;
+ p->SetDocShell(nsnull);]]
+ )],
+ [AC_DEFINE([HAVE_TYPEAHEADFIND],[1],[Define if we have tookit's typeaheadfind]) result=yes],
+ [result=no])
+
+AC_MSG_RESULT([$result])
+
dnl restore flags
CPPFLAGS=$_SAVE_CPPFLAGS
CXXFLAGS=$_SAVE_CXXFLAGS
@@ -483,7 +498,7 @@ dnl ******
dnl Python
dnl ******
-AC_MSG_CHECKING([whether python support is requested])
+AC_MSG_CHECKING([whether Python support is requested])
AC_ARG_ENABLE([python],
AS_HELP_STRING([--enable-python],[Enable python support]),