aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-01-10 07:11:36 +0800
committerChristian Persch <chpe@src.gnome.org>2005-01-10 07:11:36 +0800
commitc841a4c82601d795e75dfec0007eb9e0e3580f53 (patch)
treec20b33ec9af8b3b05109976d0944989e73a67b7a /configure.ac
parentf7c90cf8b4189935d69b2ad6a67f3708b4afe4bd (diff)
downloadgsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.tar
gsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.tar.gz
gsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.tar.bz2
gsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.tar.lz
gsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.tar.xz
gsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.tar.zst
gsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.zip
A lib/ephy-dbus.c: A lib/ephy-dbus.h:
2005-01-10 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * lib/Makefile.am: A lib/ephy-dbus.c: A lib/ephy-dbus.h: * lib/ephy-marshal.list: * src/Makefile.am: * src/ephy-shell.c: (ephy_shell_finalize), (ephy_shell_get_dbus_service): * src/ephy-shell.h: Add experimental dbus service, disabled by default. Configure with --enable-dbus to enable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 26 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a68f3e98b..61ca3b769 100644
--- a/configure.ac
+++ b/configure.ac
@@ -471,7 +471,7 @@ fi
AC_MSG_CHECKING([whether to enable native gtk+ filepicker])
AC_ARG_ENABLE([filepicker],
- AS_HELP_STRING([--enable-filepicker],[Whether to enable the gtk+ native filepicker; not neede when the mozilla build itself has native gtk+ filepicker enabled (default:enabled)]),
+ AS_HELP_STRING([--enable-filepicker],[Whether to enable the gtk+ native filepicker; not needed when the mozilla build itself has native gtk+ filepicker enabled (default:enabled)]),
[filepicker=$enableval],
[filepicker=yes])
AC_MSG_RESULT([$filepicker])
@@ -487,6 +487,31 @@ dnl ***************
AC_CHECK_HEADERS([X11/XF86keysym.h])
+dnl ***********************************
+dnl Check for DBUS and DBUS net monitor
+dnl ***********************************
+
+AC_MSG_CHECKING([whether DBUS support is requested])
+
+enable_dbus=no
+AC_ARG_ENABLE([dbus],
+ AS_HELP_STRING([--enable-dbus],[Enable DBUS (default=no)]),
+ [enable_dbus=yes],
+ [enable_dbus=no])
+
+DBUS_REQUIRED=0.22
+DBUS_GLIB_REQUIRED=0.22
+
+if test x"$enable_dbus" = "xyes" ; then
+ AC_DEFINE([ENABLE_DBUS],[1],[Define if DBUS support is enabled (default=disabled)])
+
+ PKG_CHECK_MODULES([DBUS], [dbus-1 >= $DBUS_REQUIRED dbus-glib-1 >= $DBUS_GLIB_REQUIRED])
+fi
+
+AM_CONDITIONAL([ENABLE_DBUS], [test "x$enable_dbus" = "xyes"])
+
+AC_MSG_RESULT([$enable_dbus])
+
dnl *******************************
dnl Add warning flags
dnl *******************************