aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-05-28 21:46:28 +0800
committerChristian Persch <chpe@src.gnome.org>2005-05-28 21:46:28 +0800
commita29f71709ee09ddce6da8ddd80c45b5311dd38b2 (patch)
tree5e137d0c03db4e92744f6f171b3f0f7261f47336 /configure.ac
parent72e83ac58129afa3706116830711d2a072f030c9 (diff)
downloadgsoc2013-epiphany-a29f71709ee09ddce6da8ddd80c45b5311dd38b2.tar
gsoc2013-epiphany-a29f71709ee09ddce6da8ddd80c45b5311dd38b2.tar.gz
gsoc2013-epiphany-a29f71709ee09ddce6da8ddd80c45b5311dd38b2.tar.bz2
gsoc2013-epiphany-a29f71709ee09ddce6da8ddd80c45b5311dd38b2.tar.lz
gsoc2013-epiphany-a29f71709ee09ddce6da8ddd80c45b5311dd38b2.tar.xz
gsoc2013-epiphany-a29f71709ee09ddce6da8ddd80c45b5311dd38b2.tar.zst
gsoc2013-epiphany-a29f71709ee09ddce6da8ddd80c45b5311dd38b2.zip
Check for new DBUS API.
2005-05-28 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Check for new DBUS API. * lib/ephy-dbus.c: (session_filter_func), (system_filter_func), (ephy_dbus_connect_to_system_bus), (ephy_dbus_connect_to_session_bus): Adapt to new DBUS API. Patch by Thom May, fixes bug #301153.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 20 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0880c125f..d17dc2b70 100644
--- a/configure.ac
+++ b/configure.ac
@@ -450,10 +450,27 @@ AC_ARG_ENABLE([dbus],
AC_MSG_RESULT([$enable_dbus])
-DBUS_REQUIRED=0.22
-DBUS_GLIB_REQUIRED=0.22
-
if test "x$enable_dbus" = "xyes" ; then
+
+ AC_MSG_CHECKING([for new DBUS API])
+
+ _SAVE_LDFLAGS="$LDFLAGS"
+ LDFLAGS="$LDFLAGS `$PKG_CONFIG --libs dbus-1`"
+ AC_TRY_LINK_FUNC([dbus_message_iter_get_boolean],[have_new_dbus=no],[have_new_dbus=yes])
+ LDFLAGS="$_SAVE_LDFLAGS"
+
+ AC_MSG_RESULT([$have_new_dbus])
+
+ if test "x$have_new_dbus" = "xyes"; then
+ AC_DEFINE([HAVE_NEW_DBUS],[1],[Define if compiling with DBUS 0.3])
+
+ DBUS_REQUIRED=0.32
+ DBUS_GLIB_REQUIRED=0.32
+ else
+ DBUS_REQUIRED=0.22
+ DBUS_GLIB_REQUIRED=0.22
+ fi
+
AC_DEFINE([ENABLE_DBUS],[1],[Define if DBUS support is enabled])
EPIPHANY_FEATURES="$EPIPHANY_FEATURES dbus"