aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXan Lopez <xan@igalia.com>2012-09-04 05:11:11 +0800
committerXan Lopez <xan@igalia.com>2012-09-04 19:23:13 +0800
commit18b87ec8068c5bf98aed9f507d43cba451dab665 (patch)
tree3df86b0f9c4b7b71bdaea9fd1cd93c1e0bdc30a8 /configure.ac
parent0aff80b0d783422d0db25f59c434198205d4bed7 (diff)
downloadgsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.tar
gsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.tar.gz
gsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.tar.bz2
gsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.tar.lz
gsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.tar.xz
gsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.tar.zst
gsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.zip
Add code coverage support
Needs a fairly recent gnome-common. To use do: - Run configure with --enable-code-coverage - Type 'make check-code-coverage' - Open the HTML results https://bugzilla.gnome.org/show_bug.cgi?id=683297
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 11 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 10946e853..b547181aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,6 +71,8 @@ GNOME_DEBUG_CHECK
GNOME_COMPILE_WARNINGS([maximum])
GNOME_MAINTAINER_MODE_DEFINES
+GNOME_CODE_COVERAGE
+
MORE_WARN_FLAGS="-Wdeclaration-after-statement"
DEPRECATION_FLAGS=
@@ -302,13 +304,14 @@ AC_OUTPUT
echo "
Epiphany was configured with the following options:
- Source code location : $srcdir
- Compiler : $CC
- Prefix : $prefix
- Extra debugging support : $enable_debug
-
- GObject introspection : $found_introspection
- NSS support : $enable_nss
+ Source code location : $srcdir
+ Compiler : $CC
+ Prefix : $prefix
+ Extra debugging support : $enable_debug
Build tests : $enable_tests
- WebKit2 : $with_webkit2
+ Code coverage : $enable_code_coverage
+
+ GObject introspection : $found_introspection
+ NSS support : $enable_nss
+ WebKit2 : $with_webkit2
"