aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXan Lopez <xan@gnome.org>2009-08-26 16:44:28 +0800
committerXan Lopez <xan@gnome.org>2009-08-26 16:45:38 +0800
commiteea4e5155ed3102ee21c57958a29603ed0f5166f (patch)
treea491d714dd8c7bc61c5a00eaf74dbff952e808c1 /configure.ac
parentec783faa3c1737dfd80fd53a8113bbb3aa1c06a0 (diff)
downloadgsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.tar
gsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.tar.gz
gsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.tar.bz2
gsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.tar.lz
gsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.tar.xz
gsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.tar.zst
gsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.zip
Import passwords from the ephy/gecko profile on first run.
This feature requires NSS, so NSS is added as an optional dependency, enabled by default. Can be disabled with --disable-nss, but then passwords won't be imported.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b06ecb7ba..b7171c4d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -277,6 +277,26 @@ AM_CONDITIONAL([ENABLE_SEED],[test "$enable_seed" = "yes"])
AC_SUBST([EPIPHANY_FEATURES])
+# ***
+# NSS
+# ***
+
+AC_MSG_CHECKING([whether NSS support is requested])
+AC_ARG_ENABLE([nss],
+ [AS_HELP_STRING([--enable-nss], [Enable NSS support (default: enabled)])],
+ [], [enable_nss=yes])
+AC_MSG_RESULT([$enable_nss])
+
+if test "$enable_nss" = "yes"; then
+ EPIPHANY_FEATURES="$EPIPHANY_FEATURES nss"
+ PKG_CHECK_MODULES([NSS], [nss])
+
+ AC_DEFINE([ENABLE_NSS], [1], [Define to compile with NSS support])
+fi
+
+AM_CONDITIONAL([ENABLE_NSS],[test "$enable_nss" = "yes"])
+AC_SUBST([EPIPHANY_FEATURES])
+
# *******************
# Additional features
# *******************
@@ -482,5 +502,6 @@ Epiphany was configured with the following options:
NetworkManager support : $enable_network_manager
GObject introspection : $enable_introspection
Seed support : $enable_seed
+ NSS support : $enable_nss
Build tests : $enable_tests
"