aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-11-27 22:18:42 +0800
committerChristian Persch <chpe@src.gnome.org>2005-11-27 22:18:42 +0800
commita7e1467e5987baf6ea4a1a2a359b8d87706870fc (patch)
tree5412de314fede00d81fefa51b99e8e838b9ba90d /configure.ac
parent6c86554eba317d7fcf518c02f3749cc727ec0ddd (diff)
downloadgsoc2013-epiphany-a7e1467e5987baf6ea4a1a2a359b8d87706870fc.tar
gsoc2013-epiphany-a7e1467e5987baf6ea4a1a2a359b8d87706870fc.tar.gz
gsoc2013-epiphany-a7e1467e5987baf6ea4a1a2a359b8d87706870fc.tar.bz2
gsoc2013-epiphany-a7e1467e5987baf6ea4a1a2a359b8d87706870fc.tar.lz
gsoc2013-epiphany-a7e1467e5987baf6ea4a1a2a359b8d87706870fc.tar.xz
gsoc2013-epiphany-a7e1467e5987baf6ea4a1a2a359b8d87706870fc.tar.zst
gsoc2013-epiphany-a7e1467e5987baf6ea4a1a2a359b8d87706870fc.zip
Correctly save and restore CXXFLAGS.
2005-11-27 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Correctly save and restore CXXFLAGS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0526657a4..21a5056d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -207,10 +207,10 @@ dnl **********************************
dnl FIXME find a m4/autoconf guru who can distill this into a nice macro
AC_LANG_PUSH([C++])
-_SAVE_CFLAGS=$CXXFLAGS
-_SAVE_CPPFLAGS=$CPPFLAGS
+_SAVE_CXXFLAGS="$CXXFLAGS"
+_SAVE_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="-I$MOZILLA_INCLUDE_ROOT -I$MOZILLA_INCLUDE_ROOT/pipnss `$PKG_CONFIG --cflags-only-I $MOZILLA-xpcom`"
-CXXFLAGS="$_SAVE_CXXFLAGS $AM_CXXFLAGS `$PKG_CONFIG --cflags-only-other $MOZILLA-xpcom`"
+CXXFLAGS="$CXXFLAGS $AM_CXXFLAGS `$PKG_CONFIG --cflags-only-other $MOZILLA-xpcom`"
dnl Sigh Gentoo has a rubbish header layout
dnl http://bugs.gentoo.org/show_bug.cgi?id=100804