aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2006-05-11 02:07:03 +0800
committerChristian Persch <chpe@src.gnome.org>2006-05-11 02:07:03 +0800
commit24b71aa8ac7de8dd140092705bb7cc439f6b3309 (patch)
tree65631a3c5c3b28414788e1f9ef060962b95de9a1 /configure.ac
parentc3a7867c638dd105405fa2078b2de828a318b909 (diff)
downloadgsoc2013-epiphany-24b71aa8ac7de8dd140092705bb7cc439f6b3309.tar
gsoc2013-epiphany-24b71aa8ac7de8dd140092705bb7cc439f6b3309.tar.gz
gsoc2013-epiphany-24b71aa8ac7de8dd140092705bb7cc439f6b3309.tar.bz2
gsoc2013-epiphany-24b71aa8ac7de8dd140092705bb7cc439f6b3309.tar.lz
gsoc2013-epiphany-24b71aa8ac7de8dd140092705bb7cc439f6b3309.tar.xz
gsoc2013-epiphany-24b71aa8ac7de8dd140092705bb7cc439f6b3309.tar.zst
gsoc2013-epiphany-24b71aa8ac7de8dd140092705bb7cc439f6b3309.zip
Drop support for gecko 1.7.
2006-05-10 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * data/glade/prefs-dialog.glade: * embed/ephy-favicon-cache.c: (ephy_favicon_cache_get): * embed/mozilla/AutoJSContextStack.cpp: * embed/mozilla/ContentHandler.cpp: * embed/mozilla/ContentHandler.h: * embed/mozilla/EphyAboutModule.cpp: * embed/mozilla/EphyAboutModule.h: * embed/mozilla/EphyBrowser.cpp: * embed/mozilla/EphyBrowser.h: * embed/mozilla/EphyContentPolicy.cpp: * embed/mozilla/EphyContentPolicy.h: * embed/mozilla/EphyDirectoryProvider.cpp: * embed/mozilla/EphyFind.cpp: * embed/mozilla/EphyFind.h: * embed/mozilla/EphyHeaderSniffer.cpp: * embed/mozilla/EphyHeaderSniffer.h: * embed/mozilla/EphyHistoryListener.cpp: * embed/mozilla/EphyHistoryListener.h: * embed/mozilla/EphyPromptService.cpp: * embed/mozilla/EphySidebar.cpp: * embed/mozilla/EphySidebar.h: * embed/mozilla/EphySingle.cpp: * embed/mozilla/EphySingle.h: * embed/mozilla/EphyUtils.cpp: * embed/mozilla/EphyUtils.h: * embed/mozilla/EventContext.cpp: * embed/mozilla/EventContext.h: * embed/mozilla/FilePicker.cpp: * embed/mozilla/FilePicker.h: * embed/mozilla/GlobalHistory.cpp: * embed/mozilla/GlobalHistory.h: * embed/mozilla/GtkNSSClientAuthDialogs.cpp: * embed/mozilla/GtkNSSDialogs.cpp: * embed/mozilla/GtkNSSKeyPairDialogs.cpp: * embed/mozilla/GtkNSSSecurityWarningDialogs.cpp: * embed/mozilla/GtkNSSSecurityWarningDialogs.h: * embed/mozilla/Makefile.am: * embed/mozilla/MozDownload.cpp: * embed/mozilla/MozDownload.h: * embed/mozilla/MozRegisterComponents.cpp: * embed/mozilla/MozRegisterComponents.h: * embed/mozilla/MozillaPrivate.cpp: * embed/mozilla/MozillaPrivate.h: * embed/mozilla/PrintingPromptService.cpp: * embed/mozilla/PrintingPromptService.h: * embed/mozilla/mozilla-download.cpp: * embed/mozilla/mozilla-download.h: * embed/mozilla/mozilla-embed-event.cpp: * embed/mozilla/mozilla-embed-event.h: * embed/mozilla/mozilla-embed-find.cpp: * embed/mozilla/mozilla-embed-find.h: * embed/mozilla/mozilla-embed-persist.cpp: * embed/mozilla/mozilla-embed-persist.h: * embed/mozilla/mozilla-embed-single.cpp: * embed/mozilla/mozilla-embed.cpp: * embed/mozilla/mozilla-embed.h: * embed/mozilla/mozilla-notifiers.cpp: * embed/mozilla/mozilla-notifiers.h: * embed/mozilla/mozilla-x509-cert.cpp: * embed/mozilla/mozilla-x509-cert.h: * lib/ephy-gui.c: * lib/ephy-gui.h: * lib/ephy-langs.c: * m4/gecko.m4: * src/ephy-window.c: (sync_tab_security): * src/prefs-dialog.c: (prefs_dialog_init): Drop support for gecko 1.7.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac106
1 files changed, 11 insertions, 95 deletions
diff --git a/configure.ac b/configure.ac
index 55a964654..671909a40 100644
--- a/configure.ac
+++ b/configure.ac
@@ -179,12 +179,15 @@ AC_SUBST([MOZILLA_HOME])
AC_SUBST([MOZILLA_PREFIX])
AC_SUBST([MOZILLA_EXTRA_LIBS])
-case "$MOZILLA" in
-mozilla) min_version=1.7.9 ;;
-seamonkey) min_version=1.0 ;;
-*firefox) min_version=1.0.5 ;;
-*thunderbird) min_version=1.0.5 ;;
+# if test "$gecko_cv_gecko_flavour" != "toolkit"; then
+# AC_MSG_ERROR(["$gecko_cv_gecko_flavour" flavoured geckos aren't tasty enough!])
+# fi
+
+case "$gecko_cv_gecko" in
xulrunner) min_version=1.8 ;;
+*firefox) min_version=1.5 ;;
+seamonkey) min_version=1.0 ;;
+*) AC_MSG_ERROR([Unsupported gecko "$gecko_cv_gecko"]) ;;
esac
PKG_CHECK_MODULES([GECKO],[${gecko_cv_gecko}-xpcom >= $min_version $gecko_cv_extra_pkg_dependencies])
@@ -200,84 +203,6 @@ AC_SUBST([GECKO_LIBS])
GECKO_XPCOM_PROGRAM_CHECK
-# Changed from PRUnichar* to nsAString& in 1.8a1 and on aviary branch
-
-AC_MSG_CHECKING([whether nsIFilePicker methods expect nsAString&])
-
-GECKO_COMPILE_IFELSE([widget],
- [AC_LANG_PROGRAM(
- [[#include <nsEmbedString.h>
- #include <nsIFilePicker.h>]],
- [[nsIFilePicker *p;
- p->SetDefaultString (nsEmbedString());]]
- )],
- [AC_DEFINE([MOZ_NSIFILEPICKER_NSASTRING_],[1],[Define if nsIFilePicker uses nsAString&]) result=yes],
- [result=no])
-
-AC_MSG_RESULT([$result])
-
-# Changed in 1.8a1 and again in 1.8a3 to its present form (variant 2);
-# variant 1 is on 1.7 branch. Aviary branch also has variant 2.
-
-AC_MSG_CHECKING([for nsIContentPolicy API])
-
-GECKO_COMPILE_IFELSE([content],
- [AC_LANG_PROGRAM(
- [[#include <nsEmbedString.h>
- #include <nsIURI.h>
- #include <nsIContentPolicy.h>]],
- [[nsIContentPolicy *p;
- nsISupports *arg4;
- p->ShouldLoad(0,nsnull,nsnull,arg4,nsEmbedCString(),nsnull,nsnull);]]
- )],
- [variant=2],
- [variant=1])
-
-AC_MSG_RESULT([variant $variant])
-
-AC_DEFINE_UNQUOTED([MOZ_NSICONTENTPOLICY_VARIANT], [$variant], [Define the nsIContentPolicy API variant])
-
-# Firefox doesn't have this API (?)
-
-AC_MSG_CHECKING([for nsIXULChromeRegistry API])
-
-GECKO_COMPILE_IFELSE([content],
- [AC_LANG_PROGRAM(
- [[#include <nsEmbedString.h>
- #include <nsIChromeRegistry.h>]],
- [[nsIXULChromeRegistry *p;
- p->SelectSkin (nsEmbedCString(), PR_FALSE);]]
- )],
- [AC_DEFINE([MOZ_NSIXULCHROMEREGISTRY_SELECTSKIN],[1],[Define if nsIXULChromeRegistry::SelectSkin exists]) result=yes],
- [result=no])
-
-AC_MSG_RESULT([$result])
-
-# changed from nsIXULChromeRegistry in 1.8a4
-
-GECKO_CHECK_HEADERS([],[chrome/nsIChromeRegistrySea.h])
-
-# changed location in 1.8a6
-
-AC_MSG_CHECKING([for mozilla security compoment])
-
-GECKO_COMPILE_IFELSE([pipnss],
- [AC_LANG_PROGRAM(
- [[#include <nsIX509Cert.h>]],
- [[nsIX509Cert *c;
- c->GetIssuer (nsnull);]]
- )],
- [have_psm=yes],
- [have_psm=no])
-
-AC_MSG_RESULT([$have_psm])
-
-# This is only present on toolkit
-
-if test "$gecko_cv_gecko_flavour" = "toolkit"; then
-
-AC_DEFINE([HAVE_TYPEAHEADFIND],[1],[Define if we have tookit's typeaheadfind])
-
# Make sure we DON'T have the typeaheadfind extension
AC_MSG_CHECKING([whether typeaheadfind is broken])
@@ -312,7 +237,9 @@ if test "$have_broken_typeaheadfind" = "yes"; then
AC_MSG_ERROR([You must not compile $gecko_cv_gecko with the "typeaheadfind" extension enabled!])
fi
-fi # gecko_cv_gecko_flavour = toolkit
+# Check for PSM header(s) to infer PSM presence
+
+GECKO_CHECK_HEADERS([pipnss],[nsIX509Cert.h],[have_psm=yes],[have_psm=no])
# Make sure we don't accidentally build without PSM support
@@ -334,12 +261,6 @@ fi
AM_CONDITIONAL([HAVE_MOZILLA_PSM],[test "$enable_psm" = "yes" -a "$have_psm" = "yes"])
-# Not a simple file check due to the header being in the SDK since 1.8a6
-# https://bugzilla.mozilla.org/show_bug.cgi?id=271068
-
-GECKO_CHECK_HEADERS([passwordmgr wallet],[nsIPassword.h],
- [],[AC_MSG_WARN([nsIPassword.h not found; personal data manger will have no passwords support!])])
-
# Check whether to enable our filepicker component
AC_MSG_CHECKING([whether to enable native gtk+ filepicker])
@@ -392,11 +313,6 @@ fi
GECKO_CHECK_CONTRACTIDS([$REQUIRED_CONTRACTS],
[],[AC_MSG_ERROR([$gecko_cv_gecko needs to be compiled with at least --enable-extensions=default,$REQUIRED_EXTENSIONS])])
-# Needed since 1.8b2
-# Define this down here so it doesn't affect the API checks above
-
-AC_DEFINE([MOZILLA_INTERNAL_API],[1],[Define for access to internal mozilla API])
-
# ***************
# Multimedia keys
# ***************